New File Preferences

Understanding Template (Stationery) Documents

Whenever you choose the menu command: File > New, Nisus Writer Pro opens a document window called “Untitled”.

Where did this come from?

We, the nice people at Nisus Software Inc. supply you with a versatile tool, the Nisus New File. This file is variously called (in different applications) a “stationery”, “template” or “master” document.

Apple uses the phrase “Stationery pad” in the Finder. You can turn any file into a “Stationery pad” by clicking the appropriate checkbox in the window that appears when you choose the menu command: File > Get Info in the Finder. The stationery pad is like one of those little pads your physician has for his or her prescriptions, or those pads of paper you get from your local realtor with his or her photograph and contact information at the top of each page and room for you to make your own “to do list” or “shopping list” or simply doodle to your heart's content.

So it is in Nisus Writer Pro. You can create any number of “stationery” documents. Each one can have whatever name, text and/or formatting (even window shape and location) you want. Every time you open that stationery document the information you've saved in it appears and the file is called “Untitled”… ready for you to add new content and save as a unique document.

Your Nisus New File new uses the system paper size as explained in “Set the preferred paper size for all your documents” on page 168 unless you change it here.

As a convenience Nisus Writer Pro will at first pick up the paper size set in your system’s “Print & Fax” preferences as explained in “Set the preferred paper size for all your documents” on page 168. You can customize the paper size of new documents, by editing the Nisus New File.

The Nisus New File is special “stationery” which opens whenever you choose the menu command: File > New.

In addition to the Nisus New File, Nisus Writer Pro also enables you to create a Plain Text Template, the file that is used whenever you open a file that is plain text (as identified by the “.txt” at the end of the files name).

Creating and using “template” files for specific tasks saves you time. For example, create different stationery for letters, memos, reports, and forms. You can create as many template files as you want. A template file always opens as an untitled file.

You can create and maintain a collection of different template files using the Document Manager. This is explained in detail beginning on page 73.

There are several tools for creating and modifying stationery (template) files. The first among these is the Nisus New File which is explained in detail on pages 585 - 587.

Make any file a template file

1. Choose the menu command: File > Save As….

2. Choose Document Template from the File Format pop-up menu in the Save As dialog.

image-489.png

Figure 502
Saving a file as a document template

3. Name the file what you want.

4. Save the file in any location you want (preferably some place where you’ll remember you left it).

The Document Manager (explained in detail beginning on page 73) can help you keep track of these files.

5. Click Save as illustrated in Figure 502.

Set the appearance “View” of your Nisus New File

The View portion of the New File preferences pane.png

Figure 503
The View portion of the New File preferences window

Determine which of the three primary views of your document displays when you choose New

In the View portion of the New File preferences window you can:

Choose Draft View, Page View or Style Sheet from the View pop-up menu to determine the mode in which your new file opens.

Determine how your document uses Apple’s tabbed interface

You can display multiple documents in the tabs of one window (as with a Web browser). This is explained in the section: “Document Tabs” beginning on page 360. While you can set this on a window by window basis, if you always want your new documents to appear in a tab beside existing documents you can choose:

Always

Automatic, or

Never

from the Use Document Tabs pop-up menu in the View portion of the New File preferences.

Choose Measurement Display Options for New Documents

You can display measurements in either centimeters, inches, millimeters, points, or picas. Whichever option you choose in the View portion of the New File preferences determines their display on the ruler and in any dialog in which measurement options display – unless you change the unit of measurement for that particular file.

1. Choose the menu command: Nisus Writer Pro > Preferences > New File.

2. Choose the unit type you want from the Units pop-up menu in the View area at the top of the dialog as illustrated.

You can change the unit of measurement on a per document basis.

Determine the unit of measurement in any document

Choose the units you want from the menu View > Rulers.

The various units of measurement options on the ruler.png

Figure 504
The various
units of measurement options on the ruler

Choose Centimeters (cm), Inches (in), Millimeters (mm), Picas (pc), or Points (pt) from the (measurement) Units pop-up menu to determine what your ruler displays.

Determine how the Palette Dock appears in relation to new files

Choose Most Recent, Shown, or Hidden from the Palette Dock pop-up menu to determine whether or not the Palette Dock appears as you open a new document window.

Most Recent means that, if you have opened a file and displayed the Palette Dock, the next New (“Untitled”) file you open will have the Palette Dock open. If, on the other hand, you have opened a file and closed the Palette Dock, the next New (“Untitled”) file you open will display without the Palette Dock.

If, however, you Palette Dock floats, these options are disabled.

Determine how the Comment title bars appear in relation to new files

Choose whether your Comments show: Author Name (the default), Author Name, Date and Time, Author Name and Date, Date and Time, or No Title Bar at all.

Determine how the Tracked Changes title bars appear in relation to new files

Choose whether your Tracked Changes show: No Title Bar (the default), Author Name, Date and Time, Author Name and Date, Author Name, or the Date and Time.

You can add a wide variety of information to your Nisus New File. For an example of what you might consider see “Use Automatic Numbers, Date & Time Variables and Document Properties in Headers/Footers” on page 190.

Determine whether or not “Invisibles” display in all new files

Turn on or off “Invisibles” to have Nisus Writer Pro display or hide “formatting” characters including a box surrounding any images in your document.

Check Show invisibles (tabs, newlines, page breaks, etc.) to either display of invisibles in all new documents.

At any time, you can choose the menu command: View > Show Invisibles to display

Dots for spaces

Tildes ~ for non-breaking spaces (-spacebar)

Little boxes for the ideograph space (used in East-Asian languages),
Unicode U+3000

Vertical bar with arrows for reverse direction markers for bidirectional text

Arrows where tabs occur (left to right and right to left, depending on the direction of the text)

Paragraph symbols at the end of paragraphs (left to right and right to left, depending on the direction of the text)

“Turn around arrows” where soft returns appear (left to right and right to left, depending on the direction of the text)

Inserted page breaks (using the menu command: Insert > Page Break)

Section breaks (using the commands of the menu Insert > Section Break)

“X-ed out boxes” for “gremlins” (see the Glossary (page 691) for a definition of gremlin).

Shape bounding boxes around inline images

Anchors indicating where floating shapes are attached

Some are rather esoteric. You can see all of them illustrated in Table 32.


Invisibles

Character Name

Invisible Mark

Unicode

Space

image-72-1-1-1-1-1-1.jpg

U+0020

Tab

image-182-2.jpg

U+0009

Return

image-183-1-1.jpg

U+000A

Soft Return

image-206-1-1.jpg

U+2028

Page Break

image.pict-64.jpg

U+000C

Section Break

image.pict-64-1.jpg

U+000C

Non-breaking Space

image-209-1-1.jpg

U+00A0

Ideographic Space

image-210-1-1.jpg

U+3000

Zero-width Space

image-219-1.jpg

U+200B

Left-to-Right Marker,

Push Left-to-Right

image-261-2.jpg

U+200E

U+202D

Right to Left Marker,

Push Right-to-Left

image-262-2.jpg

U+200F

U+202E

Pop Direction

image-284-1.jpg

U+202C

Zero-Width Non-Joiner

image-490.jpg

U+200C

Zero-Width Joiner,

Word Joiner

image-286-1.jpg

U+200D

U+2060

Gremlin

image-287-1.jpg

many

Anchor (appears at the end of a paragraph to which a floating shape is attached)

image-491.jpg


Indicator that paragraph Grouping controls are associated with the paragraph

image-492.png


Table 32
Invisibles”

Customize the color of your Invisibles

1. Open Nisus Writer Pro’s Appearance preference pane.

2. Select Invisibles & Guides in the left column, at the bottom.

3. Select Invisibles in the second column.

4. Click the Invisibles color swatch and choose the color you want from the Colors panel.

Determine whether or not Page guides display in all new files

Turn on or off “Page Guides” to have Nisus Writer Pro add (or remove) a color-customizable line around the area of the page (in Page View) which indicates the page’s margins. This also determines the display of the “Click for Header” and “Click for Footer” (and their variants) prompt that appears at the top or bottom of each page.

Uncheck Show Page Guides to prevent the guides from appearing in new files.

Page Guides (with .jpg

Figure 505
Page Guides (with “Click for Header”) showing

Page Guides not showing.png

Figure 506
Page Guides not showing

If the page guides do not show you cannot drag them to alter the margins. If however the page guides show you can drag them. To prevent accidental dragging choose the menu command: View > Page Guides > Lock Page Guides.

Customize the color of your Page Guides

1. Select Invisibles & Guides in the left column at the bottom of the Preferences window.

2. Select Page guides in the second column.

3. Click the Page guides color swatch and choose the color you want from the Colors panel.

Determine whether or not paragraph formatting icons display in all new files

You can set Nisus Writer Pro so that the paragraph formatting icons, described in the section: “The rulers” on page 14, appear in each new file.

Check (turn on) Show Paragraph Formatting Icons.

Determine whether or not your spelling is checked as you type in all new files

You can change this in each individual file. However, if you want to have 

Turn on or off Check Spelling as You Type to have Nisus Writer Pro add the squiggly red line under misspelled words (or not). You can change the color of this squiggly line using the Appearance preferences of Nisus Writer Pro as explained in “Misspelled” beginning on page 568.

Set the “Format” of your Nisus New File

The Format portion of the New File preferences pane.png

Figure 507
The Format portion of the New File preferences window

In the Format portion of the New File preferences window you can

Choose the Style you want your New file to be in by choosing that Style from the Style pop-up menu.

A Sample of how your text will appear (in whatever style you chose as the primary style in the Nisus New File appears in the right-hand portion of the window.

To learn more about how to use styles in your document see “Format Documents Using Style Sheets” on page 138.

The following options override the settings determined by the style you choose as the primary style in the document.

Choose the language you want your New file to be in by choosing that language from the Language pop-up menu.

To learn more about how to set the language of your document see “Set up language support” on page 40.

Nisus Writer Pro determines the direction of your document from the language you select.

Click Font to set the font Family, Typeface and Size of your text as illustrated in 584.

image-493.png

Figure 508
The Font panel

Check any options you want for Bold and/or Italic.

Click Color to open and choose a color from the Colors panel as illustrated in Figure 384 on page 432.

Click the alignment and enter the values you want for line and paragraph spacing in the area provided.

All New documents will have the formatting you set in this preference.

Set certain “Advanced” aspects of your Nisus New File

The Advanced portion of the New File preferences pane showing default location of the Nisus New File.png

Figure 509
The Advanced portion of the New File
preferences window showing default location of the Nisus New File

Edit your Nisus New File

The Nisus New File shipped with Nisus Writer Pro illustrated in Figure 12 on page 8 represents little more than a blank sheet of paper with area for headers/footers and a number of embedded styles. If you want to modify your Nisus New File, for example change the margins or add information (such as the page number variables) you need to make these alterations in the actual file.

1. Choose the menu command: Nisus Writer Pro > Preferences > New File.

2. Click the Advanced tab immediately beneath the Toolbar.

3. Choose Nisus New File from the Template File pop-up menu.

4. Click Open For Editing….

5. Make the changes as desired.

Your Nisus New File new uses the system paper size as explained in “Set the preferred paper size for all your documents” on page 168 unless you change it here.

As a convenience Nisus Writer Pro will at first pick up the paper size set in your System Preferences “Printers & Scanners” as explained in “Set the preferred paper size for all your documents” on page 168. You can customize the paper size of new documents, by editing the Nisus New File.

6. Save and close the file.

Create a template for plain text documents

If you work with many plain text files (files that have no special formatting) you can determine the basic font, size, etc. of the file that Nisus Writer Pro uses as a template when you open them.

1. Follow steps 1 through 2 above.

2. Choose Plain Text Template from the Template File pop-up menu.

3. Click Open For Editing….

4. Make the changes as desired.

5. Save and close the file.

Create a template for macro files

If you create a number of macros you can determine the basic font, size, etc. of the file that Nisus Writer Pro uses as a template when you open them.

You can learn about writing Nisus Writer Pro macros beginning on page 619.

1. Follow steps 1 through 2 on page 585 above.

2. Choose Macro Template from the Template File pop-up menu.

3. Click Open For Editing….

4. Make the changes as desired.

5. Save and close the file.

See the Nisus New File. Plain Text, or Macro Template in the Finder

If you have saved and used a version of the Nisus New File and/or the Plain Text Template in a location on your disk other than the original location, you can have Nisus Writer Pro show the files in the finder.

Click Reveal In Finder… in the Advanced portion of the New File preferences window.

Use an existing file as a Nisus New File

When you choose the menu command: File > New, Nisus Writer Pro looks for a template document called “Nisus New File.dot” in the Templates folder inside the Nisus Documents folder which is in the Documents folder of your User folder. If it is found, it will be opened and named Untitled.

You can, however, use any Nisus Writer Pro readable file on your hard drive as the file opened when you choose New.

Choose a different file for your Nisus New File

You can designate any Nisus Writer Pro readable file on your hard drive as your Nisus New File.

1. Follow steps 1 through 2 on page 585 above.

2. Click Choose… in the Advanced portion of the New File preferences window.

3. Navigate in the Open dialog to the file you want to use.

4. Click Open.

The Advanced portion of the New File preferences pane showing a different Nisus New File selected.png

Figure 510
The Advanced portion of the New File
preferences window showing a different Nisus New File selected

Nisus Writer Pro indicates the location of the file in the field at the top of the preferences window.

Create a Nisus New File

You can create any file you like and save it as your Nisus New File. The Nisus New File is a special case of a template or stationery file. The Nisus New File is the file that Nisus Writer Pro opens when you choose the menu command: File > New. The easiest way to “create” a new Nisus New File is to edit the existing Nisus New File as explained in “Edit your Nisus New File” on page 585. However, you can also use the following procedure.

1. Choose the menu command: File > New.

2. Configure the document however you'd like: adjust the margins, customize view settings, add styles, edit default formatting and text insert automatic numbers and document properties to the headers and/or footers.

3. Choose the menu command: File > Save As….

4. Name the file Nisus New File.

5. Choose Document Template from the File Format pop-up menu.

6. Click Save.

7. Designate this as the preferred Nisus New File by following the instructions described in the section: “Choose a different file for your Nisus New File” on page 586.

Restore the “factory settings” of your Nisus New File

If, for any reason you want to begin anew (Spring Cleaning, and all that) and, after many modifications, you want to use the formatting and file which Nisus Writer Pro ships as your Nisus New File, the process is simple.

Click Restore Factory Settings in the Advanced portion of the New File preferences window.

Figure 503 on page 578, Figure 507 on page 583 and Figure 509 on page 585 illustrate these settings.


Previous Chapter
QuickFix Preferences
<<  index  >>
 
Next Chapter
Saving Preferences