Bookmarks and Cross-references

Use bookmarks in your document as you would use a bookmark for quick access to a specific page in a book or a location on the World Wide Web.

You can also use bookmarks to insert “See also” cross-references in your document which Nisus Writer Pro keeps current for you.

The Bookmarks and Cross-references interface

Nisus Writer Pro offers a number of ways to work with your bookmarks and cross-references.

The Insert menu has the Bookmarks and Cross-references submenus. These are described in the Appendix beginning on page 660 as well as in the section: “Add Cross-References to Your Text” beginning on page 306.

A Bookmarks button on the Toolbar with an accompanying menu that offers point-and-click quick access to most of the commands of the Bookmarks and Cross-references submenus, illustrated in Figure 275.

image-296.png The Bookmarks button on the Toolbar (activated).png

Figure 275
The Bookmarks button on the Toolbar

The button has two states. The menu commands differ with each state:

when there is no selection or plain text is selected (on the left)

▪︎ Add Bookmark

▪︎ Add Bookmark As…

▪︎ Insert Cross-reference…

▪︎ Show Bookmarks in Navigator

▪︎ Select Next Bookmark

▪︎ Select Previous Bookmark

when bookmarked text, a cross-reference is selected, or the selection is immediately to the right or left of such text (on the right)

▪︎ bookmarked text selected:

▫︎ Remove Bookmark

▫︎ Rename Bookmark…

▫︎ Select Cross-References

▫︎ Show Cross-References in New Window

▫︎ Copy New Cross-Reference

▫︎ Show Bookmarks in Navigator

▫︎ Select Next Bookmark

▫︎ Select Previous Bookmark

▪︎ cross-reference text selected:

▫︎ Go to Target

▫︎ Page Number

▫︎ Paragraph Number

▫︎ Line Number

▫︎ Section Number

▫︎ List Item Number

▫︎ Paragraph Text

▫︎ “Above” or “Below”

▫︎ Link in PDF

▫︎ Include “Above” or “Below”

A Bookmarks palette illustrated in Figure 276 which also offers quick access to most of the commands of the Bookmarks and Cross-references submenus.

image-2-3.png

Figure 276
The Bookmarks palette with no bookmarks selected

Contextual menus, depending on whether you select bookmarked or cross-referenced text similar to those of the Bookmarks button on the Toolbar.

You can display all the bookmarks in your document in the Navigator sidebar (either in alphabetical order or in the sequence in which they appear in the document. A + and a - in the lower left corner enable you to add or remove bookmark(s) to/from selected text.

The following instructions begin by explaining the basics using the menu commands, though most of these commands are also available from the other tools described above.

Set a Bookmark

1. Select the text you want to mark.

2. Choose the command: Add Bookmark either:

from the menu: Insert > Bookmarks,

from the contextual menu that appears when you press or “right click” your mouse or “secondary click” your trackpad,

from the Bookmarks button on the Toolbar,

from the Gear menu in the lower left corner of the Bookmarks palette,

the + in the lower left corner of the Navigator sidebar.

Nisus Writer Pro automatically uses the selected text as the bookmark’s name.

When you add a bookmark automatically Nisus Writer Pro appends the word (Automatically) to distinguish it those you set with text other than that selected. You can modify that appended term in the Appearance preferences of Nisus Writer Pro as explained on page 564.

Set a bookmark as something other than selected text

1. Select the text you want to mark.

2. Choose the command: Add Bookmark As….from the various options as explained in step 2 above.

image-3-2.png

Figure 277
The Add Bookmark As sheet

You can type or paste copied text into the Bookmark Name box.

3. Click Add Bookmark.

While you can edit the bookmarked text of either, Add Bookmark and Add Bookmark As… bookmarks differ in one significant way.

The “name” of an “automatic bookmark” (what appears in the list of bookmarks in the Navigator and in the Cross Reference dialog) changes as you edit it.

The “name” of a “bookmark as bookmark” (what appears in the list of bookmarks in the Navigator and in the Cross Reference dialog) does not change.

The text each of them represents in any cross-reference where it appears in the document changes as you type.

Edit an automatically named bookmark

1. Place your insertion point at least one character in from either the end or the beginning of the bookmarked text.

2. Add whatever text you want to add to the marked text.

3. Remove the “leading” or “trailing” character.

For example, suppose you have marked the word “word” but you want to change it to read “sword” and still have it all marked so that you can cross-reference to the text.

4. Put your insertion point to the right of the “w”
w|ord

5. type “sw”
wsword

6. delete the “w” at the beginning of the word
sword

Conversely to change “word” into “words” and still have the entire word marked…

7. Put your insertion point to the left of the “d”
wor|d

8. type “ds”
wordsd

9. delete the “d” at the end of the word
words

Edit the name of a “Bookmark as…” bookmark

1. Select any part of the bookmarked text.

2. Choose Rename Bookmark… from any of the options listed in 2 of the section Set a Bookmark on page 298.

A sheet appears in which you can rename the bookmark.

3. Type the name you want for the bookmark.

If you edit the bookmark name so it matches the name of another bookmark in the document, or

If you edit the bookmark name but then revert it back to the original name so it conflicts with itself, you will see the message in red beneath the Bookmark Name field as illustrated in Figure 278.

Be sure to give the bookmark a unique name, as illustrated in Figure 280.

A Bookmark with that name already exists.png

Figure 278
The pre-existing bookmark name message

As soon as you start typing your bookmark’s new (unique) name, the Rename Bookmark button becomes enabled as illustrated in Figure 279.

Renaming a bookmark.png

Figure 279
Renaming a bookmark

image-4-2.jpg

Figure 280
The rename bookmark dialog

4. Click Rename Bookmark.

Your bookmark appears, renamed in the Navigator window.

Renamed bookmark.png

Figure 281
Renamed bookmark in the Navigator

Bookmark many disparate paragraphs simultaneously

You can automatically bookmark multiple disparate paragraphs of your text, all at once. This can be useful if you want to bookmark paragraph headings, or the first few words of every paragraph.

1. Create a multipart selection.

You can learn about creating multipart selections in the sections: “Select text from different places in the document (multipart selection)” on page 51 and “Other methods of creating a multipart selection” on page 52.

2. Choose the menu command: Insert > Bookmarks > Add Bookmark.

Display the bookmarks Navigator sidebar

Choose the menu command Insert > Bookmarks > Show Bookmarks in Navigator.

Choose the menu command View > Navigator > Show Bookmarks.

Click the Bookmarks button on the Toolbar and choose the menu command: Show Bookmarks in Navigator.

Nisus Writer Pro lists all the bookmarks in your document.

At the top of the Navigator sidebar Nisus Writer Pro displays either Bookmarks or Table of Contents. You can click that label to switch the display.

You can close the Navigator by clicking the “x” on the left edge of the Navigator sidebar’s title bar or choosing the menu command: “” (Ellipsis, or Options) > Hide Navigator on the upper right edge of the Navigator sidebar. From there you can also choose either:

Show Bookmarks

Show Table of Contents

View by Location

View by Name

Rename Bookmark… (if it is a Bookmark as… bookmark).

You can modify the appearance of the Navigator sidebar.

By default it appears on the left side of your document. To display Navigator sidebar on the right side of your document:

Choose (uncheck) the menu command: View > Navigator > Attach on Left Side.

The text of the Navigator sidebar displays on a white background in Lucida Grande 12 pt. You can change the color of the background and the font to any other font and size you want in the Appearance preferences of Nisus Writer Pro as explained in “Set the font used in the Navigator sidebar” on page 564.

Use the Bookmarks palette

The Bookmarks palette can help you work with your bookmarks and cross-references in a number of ways:

Add bookmarks to text.

See if the selected text has any applied bookmarks, and rename them (if they are Bookmark as… bookmarks.

Find any cross-references using the selected bookmark.

Copy a cross-reference to the selected bookmark as explained in the section: “Quickly copy a cross-reference for easy pasting elsewhere” on page 310.

image-5-2.png

Figure 282
Bookmarks and their cross-references listed in the Bookmarks palette

image-6-2.png

Figure 283
The Gear menu of the Bookmarks palette

Jump to Bookmarked Text

1. Be sure that the Navigator is showing.

Choose either the menu command:

View > Navigator > Show Navigator or

Insert > Bookmarks > Show Bookmarks in Navigator.

2. Click the bookmark name in the Navigator.

If the Navigator sidebar is already open, displaying the Table of Contents, you can choose the menu command: Gear > Show Bookmarks at the bottom of the sidebar.

At the top of the sidebar, when the list is scrolled to the top, Nisus Writer Pro displays either Table of Contents or Bookmarks. You can click that label to switch the display.

You can close the Navigator by choosing the menu command “” (Ellipsis, or Options menu) > Hide Navigator at the top of the Navigator sidebar.

View bookmarks in alphabetical order

Choose “” (Ellipsis, or Options menu) > View by Name at the top of the Navigator sidebar.

1C8853B9-2A65-410B-95D2-01401ACB2BDF.png

Figure 284
The Navigator sidebar displaying bookmarks by name (in alphabetical order)

View bookmarks according to their location in the document

Choose “” (Ellipsis, or Options menu) > View by Location at the top of the Navigator sidebar.

You can jump back and forth to any marker in the footnotes/endnotes and the main portion of your document. You cannot bookmark text in your headers and/or footers.

If you add a bookmark by selecting text and choosing the menu command: Insert > Bookmarks > Add Bookmark and later change the text of the bookmark (as explained above), Nisus Writer Pro automatically updates the name of the bookmark in the Navigator. However, if you add a bookmark using Add Bookmark As… Nisus Writer Pro does not update the name of the bookmark in the Navigator.

Move a Bookmark

1. Select and cut the bookmarked text.

2. Paste the passage in another part of the document.

You can even paste bookmarked text into another document making the marker available in the second document.

Remove a Bookmark

1. Select any portion of the bookmarked text

2. Choose the menu command: Insert > Bookmarks > Remove Bookmark.

If you have multiple bookmarks associated with the same string of text, a sheet appears with all bookmarks in the selection highlighted. You can remove them all, or press to deselect specific bookmarks you want to retain.

The Remove Multiple Bookmarks sheet.png

Figure 285
The Remove Multiple Bookmarks sheet

3. Select the bookmark(s) you want to remove (or deselect the one(s) you want to retain).

4. Click Remove.

You can also easily delete a bookmark from selected text when the Navigator sidebar is open and set to Bookmarks.

click the - in the lower left corner of the Navigator sidebar.

See bookmarked text

Nisus Writer Pro can highlight text marked for various purposes. It can distinguish between bookmarked text and cross-referenced text.

See “Display Options for Your Documents” on page 562.

Add Cross-References to Your Text

Nisus Writer Pro automatically keeps track of all the bookmarks, list items, tables, footnotes, endnotes and any tables of contents entries you create in your document and makes them available for cross-referencing. In addition, you can add a cross-reference to any bookmark you have added to the document.

You can also add a hyperlink, a form of cross reference to any

file on your connected hard drive(s) as explained in “Add a hyperlink to any file on your connected hard drive(s)” on 312,

content available in the bookmark dialog as explained in “Add a hyperlink to any content available in the bookmark dialog” on page 312.

This allows you to keep your thoughts on the writing while Nisus Writer Pro keeps track of where certain discussions and illustrations appear. Cross-references are used extensively throughout this document.

1. Put your insertion point where you want the cross-reference to appear.

2. Choose the menu command: Insert > Cross-reference….

The Cross-reference dialog; bookmarks sorted by location in the Navigator sidebar and by display text in the Cross-reference sheet.png

Figure 286
The Cross-reference dialog; bookmarks sorted by location in the Navigator sidebar and by display text in the Cross-reference sheet

You have many options. The dialog opens listing your bookmarks. You can show them by location in the document or sort them “alphabetically” by their text. The cross-reference display the page number on which the marked text appears or in a variety of other ways.

In Figure 286 above, clicking Insert will place the page number where “John Manly’s Talk” was bookmarked at the end of the parenthesized phrase that appears at the bottom of the screen (where the pointer appears).

3. Choose the kind of item to which you want to refer from the Insert Reference to pop-up menu at the top of the dialog.

The various options include:

Bookmark

Or, if they exist in the document, any of the following:

List Item

A List Item is any paragraph in a “List” style such as those available from the List button on the Toolbar (as explained in “About Lists” on page 59) or others you may have created (such as, in this document all of the “Figure” and “Table” numbers as well as bulleted items and instruction lists). These appear in the list by their “List Item” (bullet, number or “figure”, etc.) followed by the text of paragraph.

Table

Any table inserted using the Table tools of Nisus Writer Pro. The reference displayed in the list is the first text that appears in the upper-left-most cell of the table (that has any text).

Footnote

Any footnote inserted into your document. The reference displayed in the list is the number and its text.

Endnote

Any endnote inserted into your document. The reference displayed in the list is the number and its text.

Text in TOC

Any text marked for a Table of Contents inserted into your document.

4. Locate and select the item to which you want to refer.

Click Location to display the items in the order as they appear in the document.

Typing the first few characters of the item scrolls the list to that point. In Figure 286 above, typing
jo
would select “John Manly’s Talk”.

Or:

Click Display text to display the items “alphabetically”.

Typing the first few characters of the item scrolls the list to that point. In Figure 286 above, typing
jo
would select “Joe Green”.

Based on the type of item to which you want to refer, you have a variety of options available for what appears as the cross-reference.

5. Choose what you want to have appear as the cross-reference text from the Display text pop-up menu (depending on which option you chose (in step 3 above) from the Insert Reference to pop-up menu).

Bookmark

Page Number
displays the
number of the page where the marker appears.

Paragraph Number
displays the
number of the paragraph where the marker appears.

Line Number
displays the
number of the line where the marker appears.

Section Number
displays the
number of the section where the marker appears.

List Item Number
you might
bookmark a bit of text that begins with an automatic list number; you can use this to refer to that number without mentioning the text; if you then add a return character before the bookmarked text, the cross-reference will reflect the new number.

Bookmarked Text
displays the actual text you marked.

Above” or “Below”
if your reference is nearby (within sight of the bookmark you can simply indicate that it is above or below). This text is language sensitive and can be customized in your
Language preferences (see “Automatic Text”).

List Item

Page Number
displays the
number of the page where the list item appears.

Paragraph Number
displays the
number of the paragraph where the marker appears.

Line Number
displays the
number of the line where the list item appears.

Section Number
displays the
number of the section where the list item appears.

List Item Number
displays the
number (the digit only, not any following punctuation) of the list item as in the parenthetical statement of 5 above.
If the list item is a bullet, or some other text, that bullet or other text appears.

Paragraph Text
displays only the text of the list item, not its “number” as (using instruction
5 above) illustrated here:
Choose what you want to have appear as the cross-reference text from the Display text pop-up menu (depending on which option you chose (in step 3 above) from the Insert Reference to pop-up menu).”

“Above” or “Below”
for use in conjunction with any of the other options, when you do not want to refer to the text or number directly.

Table

Page Number
displays the
number of the page where the first line of the table appears.

Paragraph Number
displays the
number of the paragraph where the marker appears.

Line Number
displays the
number of the line where the first line of the table appears.

Section Number
displays the
number of the section where the first line of the table appears.

“Above” or “Below”
for use in conjunction with any of the other options, when you do not want to refer to the text or number directly, or when the referent is obvious.

Footnote or Endnote

Page Number
displays the
number of the page where the footnote or endnote appears.

Paragraph Number
displays the
number of the paragraph where the marker appears.

Line Number
displays the
number of the line where the footnote or endnote appears.

Section Number
displays the
number of the section where the footnote or endnote appears.

Note Number
displays the
number of the note.

Above” or “Below”
for use in conjunction with any of the other options, when you do not want to refer to or display the text or number, or when the referent is obvious.

Text in TOC

Page Number
displays the
number of the page where the footnote or endnote appears.

Paragraph Number
displays the
number of the paragraph where the marker appears.

Line Number
displays the
number of the line where the footnote or endnote appears.

Section Number
displays the
number of the section where the footnote or endnote appears.

Marked Text
displays the actual text you marked for the Table of Contents.

Above” or “Below”
for use in conjunction with any of the other options, when you do not want to refer to or display the text or number, or when the referent is obvious.

6. Determine whether or not you want the text “above” or “below” to appear in relation to the text and check:

Append “above” or “below” after number.
Certain options in the
Display Text popup menu enable you to append “above” or “below” directly to the cross-reference these include

Page Number

Paragraph Number

List Item Number

Note Number.

7. Determine whether or not you want the hyperlink maintained if and when you save your file as a PDF document:

Click Hyperlink to target when saved as PDF.

After you save your file as a PDF, when you open the file in Adobe Acrobat Reader or Apple’s Preview applications you will be able to click the cross-references and select the bookmarked text or page.

You can modify the way your hyperlinked text appears in the PDF as explained in the section: “Modify the appearance of linked text in PDF files” on page 555.

8. Click Insert.

Your cross-reference appears at the location of the insertion point. It is one “character” in your document, even though it may consist of an entire paragraph of text.

Quickly copy a cross-reference for easy pasting elsewhere

If you have many bookmarks in your document, it can sometimes be unwieldy to open the Cross-reference sheet, scroll through the long list and select the bookmark to which you want to cross reference. It might be easier to scroll to the location of your bookmark (you can use the Bookmarks list in the Navigator), then…

1. Select the bookmarked text to which you want to cross-reference.

2. Choose the menu command: Insert > Bookmarks > Copy New Cross-Reference….

The Copy a cross reference to a bookmark sheet appears as illustrated in Figure 287.

Copy a cross reference to a bookmark.png

Figure 287
The copy a cross reference to a bookmark sheet

3. Choose how you want the cross-reference to appear in the new location from the Display Text pop-up menu as indicated in step 3 on page 307.

4. Click the checkboxes you want (Append… and/or Hyperlink…).

5. Click Copy.

6. Choose the menu command: Edit > Select > Previous Selection to return to the location you wanted the cross-reference to appear.

7. Choose the menu command: Edit > Paste.

The new cross-reference appears as illustrated in Figure 288.

03D65BE7-0D9F-4503-B3BF-9FA3C8642B3F.png

Figure 288
Pasting a copied cross-reference

Add other links

Nisus Writer Pro enables you to add a variety of links into your text.

Add a hyperlink to any content available in the bookmark dialog

1. Select the text to which you want to add the link.

2. Choose the menu command: Insert > Hyperlink > Add Link to Content….

3. Choose the kind of item to which you want the link to point as explained in step 3 on page 307.

4. Locate and select the item to which you want to link as explained in step 4 on page 308.

Because only a link is added to the selected text and nothing is inserted in the text of the document the steps explained in 5 on page 308 through 7 on page 310 do not apply.

5. Click Insert.

Add a hyperlink to any file on your connected hard drive(s)

1. Select the text to which you want to add the link.

2. Choose the menu command: Insert > Hyperlink > Add Link to File….

A variant of the Open dialog appears

3. Locate and select the item to which you want to link.

4. Click Insert Hyperlink.

When you click the link in your document, the linked file opens in the original application.

For example:

If it is a “.jpg” or other common graphic format, it will likely open in Preview.app.

If it is a “.mp3” it will open in iTunes.app.

If it is an equation, it will likely open in MathMagic or MathType.

You can also drag a file from the Finder while pressing to add a hyperlink to that file in your document.

1. Select the file

2. Click the file’s icon (if in List view click the name (not the icon)).

3. Begin to drag the file from the Finder to the Nisus Writer Pro window

The drag symbol displays as a green circle with plus in it.

4. Press the key

The drag symbol changes to display an arrow indicating it is an alias.

5. Drop the file in the Nisus Writer Pro document.

The files name appears in the NisusWriter Pro document in Hyperlink style.

When you add a hyperlink to your text, Nisus Writer Pro adds a Hyperlink character style to your document, that is by default blue and underlined, and applies that style to the linked text. You can modify the appearance of the style, or remove it altogether in the Style Sheet view.

If you do not want your text to show the Hyperlink style but still be visible as a hyperlink, you can use the Marked Text > Hyperlink color in the Nisus Writer Pro Appearance preferences as explained in “Hyperlink” on page 567.

The link and style information is preserved when you “save” or print your file as a PDF and the link is “clickable” in the PDF document. The text marking assigned in the Appearance references is not.

The contextual menu that appears when you press or “right click” your mouse or “secondary click” your trackpad enables you to Show Linked File in Finder as well as Open Link, Copy Link, Remove Link and Edit Link….


Add a hyperlink to a location on the World Wide Web

This feature and how to use it is explained in detail in the section “Insert a Link to a Location on the World Wide Web” on page 634.

Links to bookmarks differ from cross-references. Cross-references always automatically update to show appropriate information about the target. A link does not ensure that.

Find the Original “Bookmarked” Text to Which the Cross-Reference Refers

You may have marked a section of your document and then inserted a cross-reference to that marker. It often happens, in longer documents, that you forget where “figure 318” appears.

Double-click the cross-reference.

Nisus Writer Pro selects the original bookmarked text.

Hyperlink cross-referenced text when exporting as a PDF

Click Hyperlink to target when saved as PDF. as indicated in step 7 above.

After you save your file as a PDF you will be able to click the cross-references and have Adobe Acrobat Reader or Apple’s Preview select the bookmarked text or page

Highlight cross-referenced text

Nisus Writer Pro can highlight bookmarks and cross-references on screen.

See “Display Options for Your Documents” on page 562.

Broken cross-references and missing bookmarks

You may insert a cross-reference, but then later delete the targeted bookmark (perhaps accidentally). In this situation the bookmark is missing, and you have a broken cross-reference. Instead of displaying the proper information Nisus Writer will display text like:

[Bookmark "Your Bookmark Name" is missing.]

To find all such broken references before finalizing your document use the menu:

Insert > Cross-references > Find All Broken Cross-References

That opens a find results window showing all broken cross-references in your document, so you can replace or fix them.

Jump to Any Page in Your Document

You can quickly jump to any page in your document. There are two methods.

Jump to any page using the menus

1. Choose the menu command: View > Go to Page….

2. Enter the page number to which you wish to jump.

3. Choose either Logical Page Number or Physical Page Number from the pop-up menu in the dialog as illustrated in Figure 290 on page 314.

4. Click OK.

You can use this method even if your document is in Draft View. Nisus Writer Pro will automatically switch to Page View.

If you have multiple sections in your document or you have begun your page number counting at something other than 1, you can choose Logical Page Numbers from the pop-up menu. “Logical” refers to the page number as it would appear on the printed document, whereas “Physical” refers to the actual physical number of pages from the beginning of the document.

Or, when in Page View choose either Show Logical Page Numbers or Show Physical Page Numbers from the Page pop-up menu in the lower left corner of the Status Bar as illustrated in Figure 289.

image-297.png

Figure 289
The Page pop-up menu

image-298.png

Figure 290
The Go to Page sheet and its pop-up menu

Jump to any page using the Page Zoom palette

1. From the “” (Ellipsis, or Options menu) choose the menu command: Go to Page….

The Go to Page sheet, illustrated in Figure 290 appears.

2. Type the page number to which you wish to jump.

If you are in Draft View, this will switch the view to Page View.

Jump to any page using the Page Number tag in the Status Bar

Using the number display area:

1. Click your pointer in the page number display beside the Page Number tag on the Status Bar.

The area becomes a text edit box.

2. Type the page number to which you wish to jump.

Nisus Writer Pro jumps immediately to that page, you do not need to confirm the number entry.

Using the Page Number tag menu:

1. Choose the menu command: Go to Page….

2. The Go to Page sheet, illustrated in Figure 290 appears.

Type the page number to which you wish to jump.

image-299.png

Figure 291
The Go to Page field on the Status Bar

Nisus Writer Pro displays the page numbers as you type, either the physical or logical page number whichever you have chosen to display on the Status Bar.

You can use this method only if your document is in Page View, as the Status Bar does not display any page information while in Draft View.

If you have multiple sections in your document or you have begun your page number counting at something other than 1, you can choose to Show Logical Page Numbers instead Show Physical Page Numbers from the pop-up menu that appears. “Logical” refers to the page number as it would appear on the printed document, whereas “Physical” refers to the actual physical number of pages from the beginning of the document.
In this document the current “logical” page is 315 while the “physical” page (counting from the title page, shown and controlled here by using a “
Custom Property”) is 348.


Previous Chapter
Tables
<<  index  >>
 
Next Chapter
Create Tables of Contents, Outlines and Indexes