Views, Tabs, Sidebars, Splits & Focus

You can view the main text area either as it might appear on a page of paper, as a continuous scroll, or in such a way as to block out all other potential visual distractions. Yet another view displays and enables editing of all the styles that control the formatting of your document. In addition to these views, Nisus Writer Express enables you to display the bookmarks and table of contents you add to your document in sidebars that appear beside the text. If you add comments or track changes to your document these can also be displayed in sidebars on either side of or below the main text. You can also split your document window so that you can see areas of your text that are not contiguous. Nisus Writer Express can also help you focus on the immediate text by dimming all but the line or paragraph of the current selection.

Views

The controls for Page View, Draft View and Style Sheet view are available at the left edge of the default set of icons on the Nisus Writer Express Toolbar. If you want quick access to the commands, you can assign keyboard shortcuts using the Menu Keys preferences of Nisus Writer Express (if you wish to toggle back and forth). The commands are available at the top of the View menu and from the View button on the left edge of the Toolbar.

The View button

The View button offers one-click access to the various views of your document that are described below. The button has four parts: three icons on the left representing Draft View, Page View and Style Sheet view, and a reveal triangle on the right that displays additional available views in a pop-up menu.

Each of these and other ways of viewing your document are described below.

The Page View button on the Toolbar selected.png

Figure 232
The Page View button on the Toolbar selected

Page View

As explained in the section on Pagination beginning on page 291, Nisus Writer Express comes preset for your new files to display ready to print your file on paper.

To display your document as it would appear on paper:

Choose the menu command: View > Page View.

Click the Page View button on the far left of the Nisus Writer Express Toolbar.

When in Page View you can see:

The Header and Footer areas;

Footnotes (if they exist in the document);

Columns (if you have set multiple columns in your document);

Page Borders (if you have turned them on using the Page Borders palette);

The Page Guides;

You can turn the display of the guides on or off by choosing the menu command: View > Page Guides > Show Page Guides.

You can lock the page guides by choosing the menu command: View > Page Guides > Lock Page Guides (this command toggles: check to lock, uncheck to release).

When the page guides are visible you can change the margins by dragging the guides. When Show Page Guides is turned off, Lock Page Guides is automatically turned on and disabled to prevent you from accidentally altering the margins.

You can learn more in “Page guide” on page 372.

The frame around the page;

The page backdrop;

You can change the appearance of the line numbers in the Line Numbers palette and the colors of the Page Guides, Page Frame and Page Backdrop in the Appearance preferences.

Draft View

Nisus Writer Express is more responsive in Draft View because it does not need to calculate pagination, footnotes, and other complicated aspects of final layout. If your current need is to quickly get your ideas from your mind through your fingers and the keyboard so you can see them on the screen in front of you, you may prefer to write in Draft View.

In Draft View, Nisus Writer Express displays your document as though it were a continuous scroll rather than individual pages.

To display your document as a continuous scroll:

Choose the menu command: View > Draft View.

Click the Draft View button on the far left of the Nisus Writer Express Toolbar.

When in Draft View very few of the items mentioned in Page View on page 255 are visible. Of those listed above, you can only see:

You can see images of Nisus Writer Express documents displaying various aspects of Draft View:

Figure 259 on page 293 The Draft View

Figure 260 on page 294 The Draft View with an inserted page break

Figure 261 on page 295 The Draft View with an inserted page break found

Full Screen View

If you want to work on your document while minimizing distractions from other applications that might be running you can use Full Screen view. While you cannot see the Desktop nor the windows of any other application you will still receive notifications from those applications from which you have turned notifications on. You can view your document in either Page View, Draft View or Style Sheet view while in Full Screen view.

When you enter Full Screen view all aspects of your main document window remain visible as they were.

If your Palette Dock is embedded in the window, entering and exiting full screen does not change the Palette Dock’s visibility. Each document window keeps whatever palette visibility it already had.

If your Palette Dock is floating when you enter Full Screen, the Palette Dock will be visible and embedded if both the following criteria are met:

the floating Palette Dock is currently visible.
and

the Palette Dock was visible the last time Full Screen was in use for any document, (that is you did not explicitly hide the Palette Dock in Full Screen mode).

Any floating palettes that have been removed from the Palette Dock or opened from the menu: Palettes > Show Palettes will continue to float wherever they were.

image-250.png

Figure 233
The Menu Bar and options available while in Full Screen view

Moving your pointer to the top of the screen reveals the Menu Bar and a number of Full Screen view options. While you can set a number of these in the Appearance preferences and elsewhere, what you choose here will override those choices. These possibilities include:

Coloring
A pop-up menu offers:

White Background
shows your text on a white background while also showing any color attributes you have added to your text such as
Highlight, Text Color and/or Background Color.

Dark Background
shows your text as white on a black background while also showing any color attributes you have added to your text such as
Highlight, Text Color and/or Background Color.

Green Phosphor
shows your text as green on a black background while also showing any color attributes you have added to your text such as
Highlight, Text Color and/or Background Color.

Show Preferences
Opens the Appearance preferences of Nisus Writer Express where, in the
Colors portion, at the bottom of the window you can set your preferences for the Document Views controlling Full screen background, Full screen caret, Full screen gutter, and Full screen text.

Zoom

A slider where you can change the Zoom percentage of the text in the main text of your document window.

Gutter Width

A slider where you can change the size of the gutter relative to the main text of your document window.

Status Bar
A pop-up menu offers:

None
hides the entire Status Bar.

Statistics
Displays only the statistics you have chosen to display in the Status Bar

Full Bar
Displays the full Status Bar

Focus Mode

A slider where you can change the size of the gutter relative to the main text of your document window.

When you exit Full Screen the Palette Dock will be visible if both the following criteria are met:

the floating Palette Dock was visible before you entered Full Screen
and

the Palette Dock was still visible in Full Screen when you chose to exit it.

If you close the Palette Dock while in Full Screen, the additional width is given to the main document view (not the Navigator nor the Comments, nor Tracked Changes sidebars). If you have your Zoom set a fixed percentage (as displayed on the menu) or to Show Entire Page, only the Full Screen gutter will expand. If, however you have your zoom set to Show Text Width or Show Page Width, the zoom percentage (including Comments and/or Tracked Changes sidebars, though not the Navigator) will expand to fill the available space.

There are numerous ways in which you can customize your Full Screen view. These are detailed on page 356.

An image of a Nisus Writer Express document in Full Screen view can be found in Figure 307 on page 357.

Style Sheet View

The Style Sheet view of Nisus Writer Express is described in extensive detail beginning on page 132 and continuing through 159.

the Style Sheet button on the Toolbar selected.png

Figure 234
The Style Sheet button on the Toolbar selected

Document Tabs

These tabs are not to be confused with the tabs that appear on the horizontal ruler and control the spacing of characters on a line when pressing the . Those tabs are explained in the section “Set tabs” beginning on page 116.

You can display all your documents in tabs of one window that are familiar from Web browsers).

Nisus Writer Express displays a Tab Bar between the Toolbar and the Horizontal Ruler (if they are visible). At the far right of the Tab Bar a Plus + sign enables you to open a new untitled document as a new tab. If multiple tabs are open, a close button appears at the left edge of each tab when your pointer hovers over that spot. The document’s name appears in the center of the tab. Whichever tab is active determines the name of the file in the title bar of the window.

Display your documents as tabs in existing windows

You can start displaying your documents as tabs in one window in a variety of ways.

Tabbed window behaviors are partially determined by macOS. This makes their behavior hard to predict precisely in Nisus Writer Express. That said, the menu command: Window > Document Tabs > Automatic only adds documents as a new tab if a tabbed window already exists, while the menu command: Window > Document Tabs > Always will (naturally) always add a document as a tab, and the menu command: Window > Document Tabs > Never, well…, I’ll never say never, never again.

Use tabs to display your documents in one window

In a new untitled, or existing open document, choose the menu command: View > Document Tabs > Show Tab Bar. If it is a new document it will appear as illustrated in Figure 235. If it is an existing document, or, when you save the document its name appears in the title bar of the window and in the tab as illustrated in Figure 236.

Every time you choose the menu command: File > New (or click the Plus + sign or choose the menu command: View > Document Tabs > New Tab) the Untitled document (based on the Nisus New File) will appear with its Tab Bar displayed and be added to the window of any existing document as illustrated in Figure 237.

Choose the menu command: View > Document Tabs > New Tab.

If you do not have the Tab Bar turned on and you do not use tabbed windows on a normal basis the menu command: New Tab will add a tab to the active window. This does not affect the command File > New, which will continue to open new Untitled documents in new windows.

Choose the menu command: View > Document Tabs > Use Tabs > Always.

This automatically turns on the menu command: View > Document Tabs > Show Tab Bar. Every time you choose the menu command: File > New (or click the Plus + sign or choose the menu command: View > Document Tabs > New Tab) the Untitled document will appear with its Tab Bar displayed and be added to the window of any existing document.

Open a group of documents into one window with many tabs

If you want to open a group of documents into one window…

Choose the menu command: View > Document Tabs > Use Tabs > Always.

You can open them all at once. Select them in the Finder and choose the Finder menu command: File > Open.

If they were recently open, you can open them one after the other by choosing them from the Nisus Writer Express menu command: File > Open Recent.

The new tab always appears to the right of the latest tab opened, not to the right of whatever tab may be active.

The setting in the Use Tabs submenu is saved with the application. Therefore, if you quit Nisus Writer Express with Always turned on when you restart Nisus Writer Express and choose to open a new file, these new files will appear the Tab Bar turned on, or (if another window is already open) as tabs in another window.

If you set your menu command View > Document Tabs > Use Tabs > Automatic, they will open in separate windows.

An untitled Nisus Writer Pro window with the Tab Bar turned on.png

Figure 235
An untitled Nisus Writer Express window with the Tab Bar turned on

An untitled Nisus Writer Pro window with the Tab Bar turned on and the document saved with a name (2).png

Figure 236
An untitled Nisus Writer Express window with the Tab Bar turned on and the document saved with a name

A Nisus Writer Pro window with the Tab Bar turned on and a new tab added (and saved with a name).png

Figure 237
A Nisus Writer Express window with the Tab Bar turned on and a new tab added (and saved with a name)

Manage tabbed windows

The active tab determines the name that appears in the title bar of the window as illustrated in Figure 237.

You can rearrange the sequence of the tabs in the window by dragging them to the right or left.

You can control which tab is active by:

clicking its title with the mouse,

choose the menu command: View > Document Tabs > Show Next Tab or Show Previous Tab,

choose that tab’s document name from the Window menu,

or

choose the next or previous tab by assigning a keyboard shortcut to the Show Next Tab or Show Previous Tab using the Menu Keys preferences of Nisus Writer Express,

Using the keyboard shortcut enables you to shift between your documents (tabs) without taking your hands off the keyboard.

Closing tabs

If more than one tab exists in a window, you can close each tab individually or all at once.

Click the small “x” that appears when you hover over the left edge of the tab beneath the title bar (or Toolbar if it is turned on).

Choose the menu command: File > Close to close the active tab.

Click the red close button in the upper left corner of the document window to close all tabs at once.

Remove tabs from a window

You can only remove one tab from a window at a time. If a window has more than its own tab, the command View > Document Tabs > Show Tab Bar is disabled.

You can drag any tab out from its cluster of tabs in a window and make its window float independently of the others. Alternatively you can use the menu command: View > Document Tabs > Move Tab to New Window. Its Tab Bar remains visible and you can add additional tabs to that window by clicking the Plus + sign or choosing the menu command: View > Document Tabs > New Tab), or (if your choice in the Use Tabs submenu is Automatic or Always) choose File > New.

Collect all windows into one

You cannot combine specific open windows so that they appear as tabs in one window. However, you can combine all open windows into multiple tabs in one window.

Choose the menu command: View > Document Tabs > Merge All Windows.

If there are any open documents you do not want to merge into one window, be sure to close those before choosing the command.

Zoom In or Zoom Out

Nisus Writer Express offers a variety of tools for zooming in and out of your document, enabling you to take a close look at odd characters or get the sense of a few pages of your document. Zooming in to see what your document looks like (even on the Clipboard so you don’t have to change the view of your entire document as illustrated in Figure 238).

You can zoom using the commands of the

View menu (to which you can assign keyboard shortcuts)

Page Zoom tag on the Status Bar

Page Zoom palette.

The Clipboard zoomed to 800% to examine an unusual 13 pt character.png

Figure 238
The Clipboard zoomed to 800% to examine an unusual 13 pt character

Use the Page Zoom palette

While it does not appear in any of the default sets, the Page Zoom palette is very useful. As with the Status Bar at the bottom of each Nisus Writer Express document window, its title bar indicates (when in Page View) the page number of the currently displayed page (not the location of the insertion point), and the total number of pages in your document. A “magnifying glass” and slider indicate the percentage to which you have zoomed your window and enables quick zooming. It also offers additional tools relating to the magnification of your document’s display.

Show the Page Zoom palette

Choose the menu command: Window > Palettes > Floating Palettes > Page Zoom or View > Palettes > Floating Palettes > Page Zoom.

image-251.png

Figure 239
The Page Zoom palette

Magnify, or, zoom in and out

Click and drag the slider in the Page Zoom palette.

Double-click in the percent zoom text box and type the percent you want to increase or decrease the display.

You can have a different zoom percentage for Page View or Draft View. The percent set in Draft View is maintained in Full Screen view.

When in Page View Nisus Writer Express can zoom your page in a variety of manners.

Show the maximum width within the Page View window

In the Page View palette choose Show Text Width from the pop-up menu at the top.

This zooms your document in such a way so that the entire text width of your page is always visible while hiding the margins. As you resize the window, the page zooms.

Show the maximum width including the margins in Page View

In the Page View palette choose Show Page Width from the pop-up menu at the top.

This zooms your document in such a way so that the entire page of your document is always visible including to the edge of the page (on which it might be printed). As you resize the window, the page zooms.

Show the entire width and height in Page View

In the Page View palette choose Show Entire Page from the pop-up menu at the top.

This displays your document in a format similar to Page (or Print) Preview; it is, however, fully editable. In this view you can scroll through your document one full page at a time by clicking your pointer on the scrollbar. As you resize the window, the page zooms so that an entire page is always visible.

Show the text zoomed at a designated percentage in Page View

In the Page View palette choose Manual Zoom from the pop-up menu at the top.

This displays your document at whatever zoomed percentage you set. As you resize the window, the page zoom remains the same and portions of your document’s text may be hidden.

In addition to the tools of the Statusbar’s Page Zoom tag the Page Zoom palette contains the tools of the Page Number tag.

If you have multiple sections in your document or you have begun your page number counting at something other than 1, you can choose commands from the “” (Ellipsis, or Options menu) to Show Physical Page Numbers (that is, counting every page that would print on paper) or Show Logical Page Numbers (that is the numbers of pages you have assigned in Nisus Writer Express).

You can also choose the menu command: Go to Page…

Focus on Your Writing

With the deluge of digital data flooding into our workspace it is good to have tools that can help us focus. In addition to Full Screen view described beginning on page 255, which minimizes distractions from other applications that might be running, Nisus Writer Express can help you dim all but the paragraph or line where your insertion point happens to be.

Focus affects all open files and the setting is saved when you quit the application.

Choose the menu command: View > Focus Mode > None for Nisus Writer Express to brightly display all the text in your document.

Choose the menu command: View > Focus Mode > Line for Nisus Writer Express to brightly display only the line of your document in which your insertion point appears.

Choose the menu command: View > Focus Mode > Paragraph for Nisus Writer Express to brightly display only the paragraph of your document in which your insertion point appears.

You can set the degree to which Nisus Writer Express dims surrounding text using the Appearance preferences of Nisus Writer Express as explained in “Focus” on page 355.

Focus can be particularly useful when you are examining your document and using Find/Replace to search for a particular instance of a find expression. If you set your focus mode to Line, not only will the selection highlight (as set in the Appearance preferences of Nisus Writer Express, explained in the section: “Find & replace” on page 358) and make the found item stand out, with all other text, above and below the selection dimmed your eyes are sure to focus on what you seek.

Typewriter Scrolling

With Typewriter Scrolling you can determine how much of the visible area should appear above the selection or insertion point as you type.

25% would keep the selection near the top of the visible area.

50% would center the selection.

75% would keep the selection near the bottom of the visible area.

The setting is determined in the General preferences of Nisus Writer Express as explained in the section “Text Editing” beginning on page 353.

You need to test what is best for you in a document that is sufficiently long. If there is not enough content ( at least more than a screen), or you are typing at the very top or very bottom of the file, Nisus Writer Express can't keep the text centered because there's nowhere to scroll to.


Previous Chapter
View and Work in Documents
<<  index  >>
 
Next Chapter
Move Around in Your Documents