SOLVED!! MORE Weird Behavior with Fonts

Everything related to our flagship word processor.
Post Reply
wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

SOLVED!! MORE Weird Behavior with Fonts

Post by wwgreaves » 2013-07-19 11:29:18

I just bought six FF Din Pro fonts (R, RI, M, MI, B, BI) from FontShop.com, downloaded them, and installed them with Font Book.

In Font Book, Pages, and Ultra Character Map, they work just fine.

In Nisus Writer Pro, I get two font families (Din Pro and DinPro), each showing only a Regular font, and all text set in any font (for example, a line in Helvetica, a line in Garamond, etc.) shows up correctly, graphically on screen but is designated DinPro in Nisus Writer Pro, and I can't set any text in NWP EXCEPT in DinPro..

If I remove the FF Din Pro fonts from my system with Font Book, the problem goes away — but then I can't use the FF Din Pro fonts I just bought.

Holy Font Book, Batman! How can I fix this?!

P.S. The problems with Prensa persist, no matter what i do.
Last edited by wwgreaves on 2013-07-22 09:44:32, edited 1 time in total.

martin
Official Nisus Person
Posts: 4610
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by martin » 2013-07-19 16:10:04

This time it's me who must apologize for not getting back to you (re: your Prensa font issue). I'm very sorry about the delay.

I'm wondering if maybe the display problems you've had with the palettes are merely showing you incorrect information. That somehow because of the way your palette is displayed only one font name (eg: "Din Pro") from the full list is being shown.

We did received the screenshots you sent previously, but they're quite tiny; too small to make out what's going on in them. Could I ask that you please send along two things:

1. Take a screenshot of some text selected in Nisus Writer that has a standard font applied (eg: Times New Roman). In this screenshot also capture the drawer/palette showing that it thinks the selection has the Din Pro font applied. Please send along a full-size screenshot that hasn't been resized (cropping it to a region of interest if you want to save transmission time is okay, but it needs to be legible).
2. A copy of the document you took a screenshot of.

You can email them to me directly at:
Image

Thanks for your help. Hopefully we'll get to the bottom of this soon.

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-19 19:29:27

Martin,

I tried posting screen shots, but they were too large. I will send them to you by e-mail.

Here's what you will see:

SS6 shows that there are two Din typefaces displayed in the character palette: Din Pro and DinPro

SS7 and SS8 show that each of those typefaces shows only a Regular font.

SS7 and SS8 also show that the text I typed as Din Regular is now displayed graphically as Times.

Attached here and in the e-mail is the file I have been working on. Right now it is all screwed up. Each line in the document was typed in a different typeface. Now, although they are displayed correctly on my screen, NWP says that each line is Times New Roman.

Figure that one out.

As i said above, when I remove the FF Din Pro fonts with Font Book all these problems disappear. There appears to be some incompatibility between NWP and the FF Din Pro fonts.
Attachments
Test - Fido.zrtf
(2.82 KiB) Downloaded 263 times

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-19 23:09:14

Martin,

I don't know why, but the screen shots I send you are greatly reduced in size after I send them to you. When I attach them, they are quite large.

Can you suggest a way to fix this? Otherwise, it's off to the Apple Genius Bar with me.

User avatar
Elbrecht
Posts: 347
Joined: 2007-03-31 14:59:22
Location: Frankfurt, Germany

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by Elbrecht » 2013-07-20 04:09:26

Hi -

it's difficult to check without having the fonts you bought - but I wonder what you mean with:

"… and installed them with Font Book"

I just copy new fonts into the folder: "Mountain Lion"/Users/"ME"/Library/Fonts and "Validate/All Fonts" with Font Book then - any problematic fonts found, I "Disable" then in Font Book. That's what I use Font Book for, only…

HE
MacBook Pro i5
SSD 840/850 Pro
MacOS High Sierra 10.13.6
Nisus Writer Pro 3.0.1

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-20 11:38:36

Martin: I finally figured out that I needed to save the screen shots as JPEG documents before sending or posting them. Let's see they work in this reply.

HE and Martin:

I think you are on to something, HE.

I removed my six FF Din Pro fonts with Font Book and then reinstalled them the way you suggested, by just copying them into "Mountain Lion/Users/wwgreaves/Library/Fonts".

I still see two Din Pro typefaces in NWP (Din Pro and DinPro). The Din Pro typeface includes the six fonts I installed, whereas the DinPro typeface includes only Regular. See the attached three screen shots.

The funkiness of NWP has disappeared as well. It's now working as it should for fonts other than DinPro.

In my next reply I will attach a copy of my test file "Test - Fido" in Nisus Condensed Rich Text format.
Attachments
DinPro in NWP
DinPro in NWP
SS3 - DinPro in NWP.jpg (92.56 KiB) Viewed 8882 times
Din Pro in NWP
Din Pro in NWP
SS2 - Din Pro in NWP.jpg (92.11 KiB) Viewed 8882 times
Din Pro and DinPro in NWP
Din Pro and DinPro in NWP
SS1 - Din Pro and DinPro in NWP.jpg (92.68 KiB) Viewed 8882 times

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-20 11:40:29

Yikes! Those images are big! Clearly I'm not experienced at working with screen shots or posting graphic files.

Attached to this post is my test file: Test - Fido.
Attachments
Test - Fido.zrtf
(2.79 KiB) Downloaded 253 times

Groucho
Posts: 496
Joined: 2007-03-03 09:55:06
Location: Europe

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by Groucho » 2013-07-20 11:45:22

wwgreaves wrote:SS6 shows that there are two Din typefaces displayed in the character palette: Din Pro and DinPro
Maybe you have two versions of the same font in two different places: root library and home library. You can check with FontBook. In Collection pane, click on Computer and then on User. Do you see the same font twice with slightly different name?

Cheers, Henry.

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-20 13:39:21

Henry,

Thanks for your suggestion.

I checked. There's is only one set of Din Pro fonts on my computer.

More and more, I'm beginning to think this has something to do with NWP's font cache.

Onward,

Bill

Groucho
Posts: 496
Joined: 2007-03-03 09:55:06
Location: Europe

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by Groucho » 2013-07-20 23:17:14

You can reset the font cache, and do much more, running Onyx. It’s free.

Henry.

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-21 10:46:21

Henry,

I've used Onyx to clean my font caches — several times.

I've used Cocktail to clean my font caches — several times.

I've even deleted the fonts, used both Onyx and Cocktail in succession, reinstalled the fonts, and then used Onyx again.

The problem persists in spite of all of that..

By the way, thanks for recommending Onyx. I first learned about it from one of your posts. My MacBook Pro performs much more smoothly since I've been running Onyx on a monthly basis.

Back to the drawing board —

Bill Greaves

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Eureka!!! Fonts Problem Solved

Post by wwgreaves » 2013-07-21 14:11:58

As I suspected, the problem was caused by a Nisus Writer Pro cache.

I went to the Apple Genius Bar, and an Apple Genius took a look at my problem with DIN Pro. He deleted Nisus Writer Pro's font menu cache, relaunched NWP, and my problems were fixed. Not only was my problem with Din Pro fixed, but my problem with the display of Prensa in the font menu was fixed.

Here's what my favorite Genius did:

Shut down Nisus Writer Pro.

In Finder, click Go in the menu bar, press the option key, click on Library, which will take you to your User Library.

Click on the Application Support folder, and then click on the Nisus Writer Pro folder. Inside the NWP folder is a document titled Font Menu Cache. Delete it.

Close Finder. Relaunch Nisus Writer Pro, which will regenerate the Font Menu Cache using the currently active fonts.

Voila! Problems with DIN Pro and Prensa were fixed.

Many thanks to all who contributed this thread. Your assistance was invaluable in zeroing in on the problem. I'm going to post an original topic with this fix so others may see it.

Bill
Last edited by wwgreaves on 2013-07-22 09:05:03, edited 1 time in total.

User avatar
Elbrecht
Posts: 347
Joined: 2007-03-31 14:59:22
Location: Frankfurt, Germany

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by Elbrecht » 2013-07-22 01:27:03

Hi Bill -

your problem was with the Nisus Writer Pro "Font Menu Cache" - that's quite a different beast.
Onyx will care for "Font Cache" only…

Enjoy HE
MacBook Pro i5
SSD 840/850 Pro
MacOS High Sierra 10.13.6
Nisus Writer Pro 3.0.1

wwgreaves
Posts: 48
Joined: 2013-01-27 17:47:43

Re: HELP! MORE Weird Behavior with Fonts — This One Disastro

Post by wwgreaves » 2013-07-22 09:02:41

Henry,

Indeed! I have amended my posts to reflect that. Sometimes I have to think a long time about the obvious before it becomes the intuitive...

Onward,

Bill

martin
Official Nisus Person
Posts: 4610
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: SOLVED!! MORE Weird Behavior with Fonts

Post by martin » 2013-07-23 11:59:34

Hi Bill, I'm very happy you managed to get this problem fixed finally! I'm sorry it was NWP's fault after all (with the problematic NWP font menu cache), but it's great news that you can finally enjoy all your new fonts :)

Post Reply