How can I prevent the US English language from appearing?

Moderator: faq-editor

Post Reply
martin
Official Nisus Person
Posts: 4610
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

How can I prevent the US English language from appearing?

Post by martin » 2009-02-18 19:43:31

This topic explains how to configure your language preferences so your favorite language is dominant. Nisus Writer may default to using the English language, which some users never want to use or see.


Language of Existing Documents
Nisus Writer treats language like other kinds of text formatting (eg: font). In other words, different parts of your document text can be marked using different languages. To change the language of existing text, just select the text (or style) and apply the appropriate language.

You can apply languages in a variety of ways. For example: use the menu Format > Language. To learn more see the topic how to change languages.


Language of New Documents
Each time you create a new document a default language is used and applied to your text. Which language is applied is controlled by Nisus Writer's "New File" preferences pane:

prefp.png
prefp.png (148.12 KiB) Viewed 95 times

To change the language of new files, adjust that setting to use your desired language. If you do not see the language you want listed, please read how to change which languages are available.


Unwanted Languages Still Appear During Editing
It's important to make clear that the language like other kinds of text formatting (eg: font), and not a property of the document as a whole. Different parts of a single document can be marked in multiple languages. For example: it's possible most of your document is marked as German, but maybe a single paragraph is marked as US English.

When you copy-paste text within Nisus Writer or from an external source (web pages, Microsoft Word, etc) that text may be explicitly marked as US English or another language. The language of the source material takes precedence over any language you otherwise have applied in your document. You could strip the source language by pasting as "text only" if all formatting is not important to you. You could also change the language of the text after you paste it.

If you are pasting text from an external source it's also possible the text has no language applied. In this case Nisus Writer will assume the text should have the primary system language applied. Most Macs ship with generic "English" set as the system language, which Nisus Writer assumes is US English. Here's how to change the system language:

1. Open your macOS system preferences.
2. Switch to the "Language & Region" section.
3. Rearrange the list of preferred languages (using drag and drop) so that your favorite language is at the very top.

NOTE: you'll have to restart Nisus Writer before any changes in your system preferences take effect. This will also only affect text pasted after you make the change to your system. Text you've already pasted into Nisus documents will be unaffected; existing text will maintain its language.

sysp.png
sysp.png (114.57 KiB) Viewed 95 times

Post Reply