Reply to topic  [ 1 post ] 
How can I prevent the US English language from appearing? 
Author Message
Official Nisus Person
User avatar

Joined: 2002-07-11 17:14:10
Posts: 3688
Location: San Diego, CA
Some users never write in US English and do not want it to appear in Nisus Writer. This topic explains how to configure your language preferences so your favorite language is dominant.

Language of Existing Documents
Nisus Writer treats language like other kinds of text formatting (eg: the font). In other words, different parts of your document can be marked using different languages. To change the language of some existing text, just select the text (or style) and apply the appropriate language. You can apply languages in a variety of ways (eg: using the menu "Format > Language"), all of which are all detailed in the topic how to change languages.

Language of New Documents
Each time you create a new document a default language is applied. Which language is applied is controlled by Nisus Writer's "New File" preferences pane:
Attachment:
newfile.png
newfile.png [ 95.58 KiB | Viewed 3435 times ]
Any new files you create will use whatever language you set. If you do not see your language listed, please read how to change which languages are available.

US English Still Appears Unwanted When Editing
It's important to make clear that language is an attribute of text, like font or color, and not a property of the document as a whole. One can have different parts of a single document marked in multiple languages. It's possible part of your document has been marked as US English and another part has not.

When you copy-paste text within Nisus Writer or from an external source (like an email, Microsoft Word, etc) that text may be explicitly marked as US English. This language would take precedence over any language you otherwise have applied in your document. You could work around this by pasting as "text only" if other formatting is also not important to you, or by changing the language of the text after you paste it.

If you are pasting text from an external source it's also possible the text has no language applied. In this case Nisus Writer will assume the text should have the primary system language applied. Most Macs ship with generic "English" set as the system language, which Nisus Writer assumes is US English. Here's how to change the system language:

1. Open your OSX system preferences.
2. Switch to the "Language & Text" section.
3. If it is not already selected, click the "Languages" tab.
4. Rearrange the list of languages (by drag and drop) so that your favorite language is at the very top:
Attachment:
sys.png
sys.png [ 50.82 KiB | Viewed 3435 times ]

Please note that you'll have to restart Nisus Writer before any changes in your system preferences take effect.


2009-02-18 19:43:31
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software