hyphenate not working

Everything related to our flagship word processor.
Post Reply
Yohanan
Posts: 53
Joined: 2017-12-21 04:36:37

hyphenate not working

Post by Yohanan » 2018-09-04 04:47:00

Hi,
I am not sure why hyphenation, when selected, works fine and fast in some documents and not in others. I just created a new doc. and there it does not apply my choice of Menu/View/Hyphenation/Automatic, though in other docs recently it works fine. Does anybody have experience with the problem ? Regarding the indication in the Guide, I am sent to a place Library/Spelling which does not exist any more in High Sierra as far as I can see. (The bulk of my docs are in French and selecting this language have not caused any difficulty.
Thanks in advance for any help.

User avatar
martin
Official Nisus Person
Posts: 4278
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: hyphenate not working

Post by martin » 2018-09-04 09:25:25

One question before we get too deep in diagnosing the problem: what language is applied to your text?

Languages in Nisus Writer work like other formatting in that each bit of text in your document can have a different language applied. If you want to have French spellchecking and hyphenation, you must make sure the French language is applied to all of the text. For more on this please see our FAQ on how languages work.

If your language is correctly set for the text in question, please let me know and we can explore other possible reasons that hyphenation isn't working correctly. It would help to see an example document. Maybe you could attach a small example file here on the forum.

Yohanan
Posts: 53
Joined: 2017-12-21 04:36:37

Re: hyphenate not working

Post by Yohanan » 2018-09-10 01:44:42

Sorry, all these documents are relatively private, so I could not decide to send an image. Right now I am using Nisus somehow as a substitute to a very good old typewriter machine for I meet with too much difficulties to try to set things in order. For the moment I resign myself to go on with the app which is still attractive by its flexibility in spite of its lability.
(On the MacBook the problem previously mentioned of Templates multiplying within the folders: Glossary, Style lIbrary, etc. is back again and the app resist any attempt of mine to get a New Nisus File as I would.)

Yohanan
Posts: 53
Joined: 2017-12-21 04:36:37

Re: hyphenate not working

Post by Yohanan » 2018-09-10 01:46:27

By "lability" I mean instability. I am surprised there are not a lot of people meeting with the kind of problems I meet with.

ssampler
Posts: 85
Joined: 2006-06-29 07:56:30
Location: Hudson River Valley, NY

Re: hyphenate not working

Post by ssampler » 2018-09-14 12:34:04

Yohanan:

To ship a private document, mask everything but punctuation marks and spaces in PowerFind Pro:
Find: [a-zA-Z0-9]
Replace with: x (or your choice of letter)
Steve Samuels
sjsamuels@gmail.com

User avatar
martin
Official Nisus Person
Posts: 4278
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: hyphenate not working

Post by martin » 2018-09-17 14:30:36

Steve's suggestion is a good one. If you have a document with private content you'd rather not share with us, you can first redact it.

Instead of scrambling text manually, we also offer a Redaction Macro that does a more thorough job. The macro tried to scramble text in such a way that layout isn't drastically changed. Often times a problem that occurs in the original document will also occur in a redacted version. The macro will also excise images and scramble document metadata properties like the author.

Post Reply