Does not save spelling option for English (US)

Everything related to our flagship word processor.
Post Reply
talaivan
Posts: 21
Joined: 2007-08-18 06:37:50

Does not save spelling option for English (US)

Post by talaivan »

I want to change English (US) so that it does not mark misspelled words (format/language/edit language:spelling). In Nisus 1.1, I can change it when the program is open and it works when I open documents, but when I quit Nisus, that preference is not saved and I have to reenter it when I start the program. This is clearly a bug -- is there any way to edit the preferences (com.nisus.NisusWriter.plist) or other file to make this change permanent? Note that it does seem to save changes to "Count Words in the Language."

ProfT
Posts: 89
Joined: 2005-03-09 06:53:40
Location: La Mirada, CA

Re: Does not save spelling option for English (US)

Post by ProfT »

I was not able to replicate this with NWP 1.1. NWP maintained the preference for spelling (whether on or off) in several documents. If you are wanting this behavior in a new document the setting would need to be done in the New File settings (under Preferences in the NWP menu.

Mike

talaivan
Posts: 21
Joined: 2007-08-18 06:37:50

Re: Does not save spelling option for English (US)

Post by talaivan »

Try this. Open NWP, set spelling for English (U.S.) to disabled. Open a new file and put some misspelled words in it. They will not be marked as misspelled (wiggly orange line). Save the file. Quit NWP. Open the file you saved. The misspelled words will be marked.

Here's another question: is there a name for a macro that will make NWP automatically run it on start-up (there was in Classic). That would work around the problem, as the start-up macro could set the spelling for English (US) to disabled. Thanks.

User avatar
martin
Official Nisus Person
Posts: 4936
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Does not save spelling option for English (US)

Post by martin »

talaivan wrote:Try this. Open NWP, set spelling for English (U.S.) to disabled. Open a new file and put some misspelled words in it. They will not be marked as misspelled (wiggly orange line). Save the file. Quit NWP. Open the file you saved. The misspelled words will be marked.
Thanks for the clear list of steps to reproduce the problem- I'm seeing the errant behavior over here and will file it for fixing ASAP.
Here's another question: is there a name for a macro that will make NWP automatically run it on start-up (there was in Classic). That would work around the problem, as the start-up macro could set the spelling for English (US) to disabled. Thanks.
Unfortunately we don't have any kind of startup macro feature yet. And even if we did, manipulating user preferences isn't something the macros currently have access to.

Post Reply