Fixed line spacing is hiding in-line equations.

Everything related to our flagship word processor.
Post Reply
LongTermUser
Posts: 25
Joined: 2007-10-31 05:58:12

Fixed line spacing is hiding in-line equations.

Post by LongTermUser » 2009-04-03 19:08:16

This problem is that I have many inline equations. In using the fixed line spacing so that the line spacing is uniform for in-line equations that exceed the baselines. Even after setting the equations from MathEq to transparent the in-line equations are still cut off above the baselines. That is they are whited out.

How do I fix this?

Thank you

Lorenz

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Re: Fixed line spacing is hiding in-line equations.

Post by Ruchama » 2009-04-04 19:58:26

can you upload a short file that reflects the problem?

User avatar
phspaelti
Posts: 1045
Joined: 2007-02-07 00:58:12
Location: Japan

Re: Fixed line spacing is hiding in-line equations.

Post by phspaelti » 2009-04-05 09:01:03

I don't use MathEq myself, but the equation is basically a graphic, isn't it? And the graphic is inline, isn't it? so you are trying to put a graphic that is too large on a line of fixed height. Obviously it isn't going to fit so what do you want Nisus to do? Overwrite the line above? Something is going to have to give.
The usual solution is not to use fixed line height in cases like this. If for some reason you don't want that, and you want your equation to overlap the line/space above the line, you would have to make the equation float in front of the text. If you are trying to give the graphic space with "space before", you could make the line height bigger and the "space before" smaller.
philip

Groucho
Posts: 496
Joined: 2007-03-03 09:55:06
Location: Europe

Re: Fixed line spacing is hiding in-line equations.

Post by Groucho » 2009-04-05 10:06:17

phspaelti is correct. In my opinion, you only have two ways: either select Multiple as line spacing; or resize the equation, so it can fit in.

Greetings, Henry.

wb
Posts: 11
Joined: 2008-02-02 13:31:49

Re: Fixed line spacing is hiding in-line equations.

Post by wb » 2009-04-09 19:17:37

I've observed this issue myself in recent work. In my case, in-line equations from MathType are displayed by NWP with the top edge of the graphics box truncated. By in-line I mean not a displayed equation, on a separate line with a number perhaps, but rather typically a shorter equation that is inserted in the flow of a paragraph as a word, so to speak. Most of the time the in-line equations are not too tall to typeset with regular linespacing, so the truncation of the displayed equation should not occur.

If the paragraph's linespacing is changed from exact to multiple (e.g., from 14.5 points to 1.1 lines), the truncation goes away, and the equation is fully rendered. The truncation shows up, by the way, in printed documents as well and also in pdfs, so the way to go for now is to use multiple linespacing.

In going from 14.5 points to 1.1 lines, the gap between lines in my Times 12 point paragraph does not appreciably change, so there seems to be no reason why the graphics box in the exact linespacing case has to be truncated. Perhaps it is a layout issue that can be fixed. By the way, Microsoft Word does not exhibit this issue with the same settings.

With the hope that this issue can be fixed, I've sent in a report on this issue using the Send Feedback menuchoice on the Help menu.

Kino
Posts: 400
Joined: 2008-05-17 04:02:32

Re: Fixed line spacing is hiding in-line equations.

Post by Kino » 2009-04-10 03:31:55

Some weeks ago I encountered this problem and asked them to improve the situation in a feedback on another problem affecting the same document.

At that time, I did not see the situation well but now I think it should be possible to change NW Pro's treatment of inline images so that they are totally visible because they are so in the selected state.
InlineImage.png
InlineImage.png (21.6 KiB) Viewed 5363 times
As you see, text above or below would not be hidden by the image because the background of the image (generated by Grapher.app) is transparent.

Post Reply