Check mark fails to display sometimes

Everything related to our flagship word processor.
Post Reply
alanterra
Posts: 18
Joined: 2013-10-08 13:58:39

Check mark fails to display sometimes

Post by alanterra » 2019-02-15 14:23:13

Hi

I can't figure this out. The problem has recurred a bunch of times, but I can't figure out any rhyme or reason when.

I have a bunch of paragraphs that start with a few digits, a space, and a check mark (✓ CHECK MARK Unicode: U+2713, UTF-8: E2 9C 93). Many times when I open the document and edit it for a while, I notice that the check mark is not displayed. Most but not all of the check marks are missing.

But upon closing and reopening the document, it "comes back." (The first time I saw this happen, I thought that the characters had disappeared, so I added them back in; I was quite surprised to see double check marks the next time I opened the file!) Not all the check marks disappear, just some of them, and, so far, closing and opening the document has always brought them back. I can only guess that they disappear as I am editing the document, but I haven't caught the act of disappearing. FWIW, I am using Times Roman 12, viewing at 125%. I suspect that something is going wrong with the font substitution code, or perhaps it is related to showing invisible characters.

This is what it looks like in the document:
Screen Shot 2019-02-15 at 14.07.59.png
Screen Shot 2019-02-15 at 14.07.59.png (7.13 KiB) Viewed 1164 times
If I select that text and paste it into a new document, the check mark comes back:
Screen Shot 2019-02-15 at 14.08.30.png
Screen Shot 2019-02-15 at 14.08.30.png (8.05 KiB) Viewed 1164 times
And this is what the Formatting Examiner tells me:
Screen Shot 2019-02-15 at 14.16.03.png
Screen Shot 2019-02-15 at 14.16.03.png (94.96 KiB) Viewed 1164 times
If I could make this recur reliably, I would let you know how, but right now it is a big mystery.

alanterra
Posts: 18
Joined: 2013-10-08 13:58:39

Re: Check mark fails to display sometimes

Post by alanterra » 2019-02-15 15:19:13

I have a document that seems to reliably show this error, and I am sending it into support for examination.

Post Reply