Removing Periods after Footnote Numerals

Everything related to our flagship word processor.
Post Reply
pbuisch
Posts: 1
Joined: 2021-04-06 06:45:48

Removing Periods after Footnote Numerals

Post by pbuisch »

I am reformatting several long documents, and am now needing to remove the periods after the number in each footnote. I have tried going to Style Sheet View and deleting the period after the number in the footnote sample window, but it does not change anything in the document. And when I return to the Style Sheet View after checking it in the Page View, the period again appears after the number in the sample footnote sample window. Any help would be much appreciated. Thank you.

Vanceone
Posts: 168
Joined: 2013-05-03 07:06:31

Re: Removing Periods after Footnote Numerals

Post by Vanceone »

When you say "Sample footnote window" are you talking about the text in the preview pane of the style sheet?

Because in the footnote style sheet, there is an option under "note References" where you can control the period; it appears in the "after text" box. Delete that period and it should delete it.

User avatar
phspaelti
Posts: 1178
Joined: 2007-02-07 00:58:12
Location: Japan

Re: Removing Periods after Footnote Numerals

Post by phspaelti »

Vanceone wrote:
2021-04-06 09:06:39
Because in the footnote style sheet, there is an option under "note References" where you can control the period; it appears in the "after text" box. Delete that period and it should delete it.
But if my memory serves, this may depend on the version of Nisus you are running. Older versions inserted this "after text" as an actual text string, in which case you will need to use either Find/Replace or a Macro to modify them in bulk. There must be relevant discussions in past Forum topics.
philip

User avatar
martin
Official Nisus Person
Posts: 4924
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Removing Periods after Footnote Numerals

Post by martin »

phspaelti wrote:
2021-04-06 17:07:21
Vanceone wrote:
2021-04-06 09:06:39
Because in the footnote style sheet, there is an option under "note References" where you can control the period; it appears in the "after text" box. Delete that period and it should delete it.
But if my memory serves, this may depend on the version of Nisus you are running. Older versions inserted this "after text" as an actual text string, in which case you will need to use either Find/Replace or a Macro to modify them in bulk.
This is exactly right. Older versions of Nisus Writer did not automatically control the text after each note reference in the note area. That means each period (or whatever other text) occurs after the reference as regular editable text in the note area. You can delete the unwanted text, either manually or with find/macros.

To give you more specific advice it's probably best if you share an example document that shows your situation. If you don't want to share your file here or with us privately, you might use the redaction macro. That should result in a document that still reveals the unwanted periods, but without exposing your text.

Post Reply