Format Documents Using Style Sheets

Introduction to Style Sheets

Nisus Writer Express has multiple ways of handling the various possible combinations of fonts, sizes, colors and paragraph formats, languages and other character formats. While the vast majority of word processors allow you to define styles that apply to entire paragraphs, in Nisus Writer Express you can also apply a collection of formats to a single character. This offers you much greater control over the final look of your document as well as the manner in which you can modify it. A Style Sheet is a collection of formats associated with your document. Each style can consist of a variety of characteristics and be as precise as you want, so as to define the font, size, underline characteristic, color, spacing, line wrap, tab locations, and language. Or, a style can consist of as little as one characteristic.

Please note we use the word “style” to refer to the user defined styles (whether shipped with Nisus Writer Express or created by you, the individual user) which appear in the Style Sheet view of Nisus Writer Express, in the Character Style and Paragraph Style submenus of the Format menu, the Styles buttons on the Toolbar, and in the Styles palettes. This document uses the word “format” to refer to those other means of altering the appearance of your characters which you choose directly from the Format menu and apply individually.

Style Sheets can provide a variety of functionalities:

Styles can help you to automatically format document content including text and rulers, with a single click or keystroke using sets of predefined formats you, the user define.

Styles can help you to automatically re-format your document as you the user change any style definitions.

Styles enable you to store that formatting in a way that can be reused in other documents.

Nisus Writer Express comes with a Nisus New File that includes a number of predefined styles. These appear in the Styles palettes, the Styles buttons on the Toolbar, as well as in the Character Style and Paragraph Style submenus of the Format menu, and in the Style Sheet view of your untitled document.

You can modify these styles, or add more styles which meet your writing needs. Any formats you can apply to text using the Format menu and its submenus you can use to create a paragraph style, while those that do not affect entire paragraphs you can use to create a character style. In addition a number of the tools in various palettes are also available.

In order to have these styles available to you at any time, each time you open a “New” (Untitled) file you need to add them to your Nisus New File. Instructions on how to modify your Nisus New File are explained in “Create a Nisus New File” on page 377.

In addition, you can create any number of unique named template files with different Style Sheets in them, each one for a different purpose. You can learn more about the Nisus New File and other template documents in the section “Understanding Template (Stationery) Documents” beginning on page 367

As an alternative, you can manage your styles using the Style Library of the Document Manager. The Document Manager is explained in detail in the section “Manage… Save and Open Files” beginning on page 71. The Style Library is explained in detail in the section “Maintain a Style Library” beginning on page 148.

Working with styles makes it easy for you to experiment with the appearance of your document. Changing a style only affects the formats that are specifically linked to that style. Once you change a style, all text of that style in the document changes to match the modifications.

The various tools for using styles

Nisus Writer Express supplies a number of devices for applying styles and their attributes to your text. These include tools for applying styles, creating and editing styles, and diagnosing the formatting of your documents’ styles. Some of these tools are described in more details here and in other portions of this Guide.

Applying styles
As mentioned above, Nisus Writer Express comes with a Nisus New File that contains a variety of styles you can apply to your text. These are described beginning on page
133.

Creating and editing styles
The Style Sheet view enables you to create new styles and edit the attributes of existing styles. It is described beginning on page 138.

Diagnosing the styles and their attributes as they are applied to your document, as described in the section “Use the Formatting Examiner” beginning on page 341.

Apply a style to your text

Applying styles to your text is easy. Rather than choosing a font, then a size, then bold and/or italic and possibly a color, when you choose a style, all the formatting associated with it are applied at once.

1. Select the text to which you wish to apply the style.

2. Apply the style

Click that style’s name once in the Styles palettes.

Choose the style’s name from the Character Style or Paragraph Style button on the Toolbar.

Choose the style’s name from the Character Style and/or Paragraph Style submenus of the Format menu.

Choose the style’s name from the Character Style or Paragraph Style tag pop-up menu on the Status Bar.

When you apply a paragraph style Nisus Writer Express removes certain characteristics that may already be associated with the text and substitutes the formatting of the style you are applying.

Existing paragraph formats are always removed (for example); only one paragraph style can be associated with any string of text at one time

line spacing (leading)

paragraph spacing

indents/outdents

alignment

Character formats are removed only if the applied paragraph style defines a setting for those characteristics (for example)

font

color

italics

List formats are removed only if the applied paragraph style defines a setting for that property.

When you apply a character style (for example Emphatic) Nisus Writer Express removes all character formats that may already be associated with the text (except language)

font

color

italics

Nisus Writer Express only removes a language attribute if the applied style has a different language associated with it.

The Styles palettes interface

The styles present in the shipped Nisus New File consist of four types: character, paragraph, list, and notes. The Character Styles palette and the Paragraph Styles palette list all the styles in your document and enable you to apply a collection of attributes to selected text with one click of the mouse or trackpad. While the two palettes display character and paragraph styles by default, you can cause them to display list styles and note styles as well, as explained in “List and Note styles in the palettes” on page 136.

The styles names are listed in their palettes sorted alphabetically. Many of these supplied styles use standard names and formatting common in HTML documents. An icon identifying the type style appears along the left edge of this name in the list. If there is a keyboard shortcut associated with that style, that appears to the right of the style’s name.

The name of the style of the current selection is highlighted in gray. If a selection consists of text in more than one style (a “mixed selection”) those styles’ names in their respective palettes are highlighted with a special “Palette mixed selection” color. You can control each of these in the Appearance preferences as explained in the section: “Colors” beginning on page 356 and illustrated in Figure 113.

The Character Styles and Paragraph Styles palettes showing both mixed selection (Character Styles) and not (Paragraph Styles).png

Figure 113
The Character Styles and Paragraph Styles palettes showing both mixed selection (Character Styles) and not (Paragraph Styles)

The difference between various kinds of styles

Nisus Writer Express supports four kinds of styles

Paragraph Styles
Apply the associated formats to the entire paragraph.

Character Styles
Apply the associated formats to selected text only (and it can overlay the formatting
of a Paragraph Style). These include those that determine the appearance of the footnote or endnote reference character in the document. Character Styles toggle on or off the same way that choosing individual characteristics (such as Bold, Italic, Outline or Shadow).

List Styles
Apply to the lists you insert in your document.

Notes Styles.
Apply to the notes areas of your document.

Supplied styles

The Nisus New File that comes shipped with Nisus Writer Express contains a number of styles.

Styles of the Paragraph Styles palette

Block Quote Use for indented blocks of quoted text;

Footer Use for text in the footer. This style is already present when you click in the footer;

Header Use for text in the header. This style is already present when you click in the header;

Heading 1 Use for top level headings;

Heading 2 Use for second level headings;

Heading 3 Use for third level headings;

Heading 4 Use for fourth level headings;

Heading 5 Use for fifth level headings;

Heading 6 Use for sixth level headings;

Normal Use for your basic flowing paragraphs of text;

Title Use for your document’s title;

Styles of the Character Styles palette

Emphatic Use to emphasize smaller amounts of your text with italics;

Note Reference
Used for your note markers in your text;

Strong Use to emphasize smaller amounts of your text with bold;

Note Reference in Note
Use to determine the display of the note reference marker in your
endnotes and/or footnotes.

Styles of the List Styles palette

While there is no independent List Styles palette you can choose to display list styles in either the Character Styles or the Paragraph Styles palette.

Bullet List Uses single bullets to begin each paragraph.

Headings Uses (European) Arabic numerals (1, 1.1, 1.1.1, etc.) to number and causes the numbers to appear at the far left (or right in right to left sections), i.e. along the margin. Designed to be used in conjunction with the Heading 1, etc. styles.

Lettered List Uses letters to begin each paragraph.

Number List Uses numbers to begin each paragraph.

Outline Makes the numbering sequence like an outline.

Tiered List Resembles the Headings list, but is not designed to work in conjunction with the Heading 1, etc. styles.

Styles of the Note Styles palette

Similar to the List Styles palette, there is no independent Notes Styles palette. However, you can choose to display Notes styles in either the Character Styles or the Paragraph Styles palette.

Endnote The style applied to the endnotes in your document.

Footnote The style applied to the footnotes in your document.

The styles palettes’ menus

In addition to the close x and the reveal triangle on the left edge of the palettes’ title bar, the Styles palettes contain three menus to help you work with the styles of your document. The commands in each set differ slightly depending on which set of styles are displayed. Clockwise from the upper right corner they are:

The “…” (ellipsis, or options) menu

The commands of the “” (Ellipsis, or Options) menu control the appearance of the palette itself.

Condensed Mode

Collapses the palette so that it displays only one style with all others available in a pop-up menu.

Expanded Mode

Enlarges the palette to show a scrollable list of up to six of the available styles in the document.

You can also use the drag bar or enlarge corner illustrated in Figure 24 on page 22 to condense and expand the palettes.

Either of the two palettes can display any and all of the four sets of styles. The following four commands toggle on/off.

Show Character Styles

When checked displays all the character styles in your document. A style icon button menu, similar to the corresponding tag on the Statusbar, appears in the lower right corner of the palette to indicate which styles are available in the palette.

Show Paragraph Styles

When checked displays all the paragraph styles in your document. A style icon button menu, similar to the corresponding tag on the Statusbar, appears in the lower right corner of the palette to indicate which styles are available in the palette.

Show List Styles

When checked displays all the list styles in your document. A style icon button menu, similar to the corresponding tag on the Statusbar, appears in the lower right corner of the palette to indicate which styles are available in the palette.

Show Note Styles

When checked displays all the note styles in your document. A style icon button menu, similar to the corresponding tag on the Statusbar, appears in the lower right corner of the palette to indicate which styles are available in the palette.

It is possible to turn off the display each of the sets of styles and the palette will appear empty. Simply choose one of the commands above and the styles will reappear in the palette. Alternatively, if you remove the display of all the styles, when you drag the palette outside the Dock or return it to the Dock, that palette’s default set will be displayed.

Style Preview Mode

You can modify the display of the styles in the Styles palettes to make them WYSIWYG or not.

Nisus Writer Express generally displays your Styles palettes with the characteristics of that style so that each style’s name appears with all its character formatting. You can change this. The options are illustrated in Figure 114.

Plain Text

Removes all formatting.

Formatted Text

Displays all formatting including possible extreme height characteristics.

Formatted Text - Small Size

Displays the formatting, but maintains a similar height for all styles.

Paragraph Styles palette plain.pngParagraph Styles palette wysiwyg.pngParagraph Styles palette wysiwyg small.png

Figure 114
The Styles palette showing Plain Text, Formatted Text, and Formatted Text - Small Size views

The last two commands in the menu change depending on whether the palette is in the Dock or floating.

Attach Palette to Dock / Detach as Floating Palette

If the palette is floating, choose Attach Palette to Dock to cause the palette to return to the Dock (whether or not the Dock, and the appropriate palette group is visible).

If the palette is in the Dock, choose Detach as Floating Palette to cause the palette float independent of the Dock.

Remove Palette…

Visible only when the palette is in the Dock, choosing it will present a warning dialog, illustrated in Figure 115. While you cannot undo this action you can restore a removed palette to the Dock as explained in the section: “Customize the Dock and its Palettes” on page 396.

image-132.png

Figure 115
The remove palette warning dialog

The style icon button menu

The lower right corner of the palette displays a button similar to those that appear on the right edge of the Statusbar as illustrated and described in the section: “Formatting tags” on page 15.

The style icon button menu of the Character and Paragraph Styles palettes

The commands of these menus are identical except for where one refers to “Character” the other refers to “Paragraph”. They offer additional access to the commands of the main menu: Format > Character Style and Format > Paragraph Style.

New Character Style…

New Character Style Based on Selection

Redefine Style from Selection

Remove Character Styles

Select Next in Style

Select All in Style

The style icon button menu of the List Styles palette

The commands of the List style icon button menu mirror those of the top portion of the commands of the main menu: Format > Lists.

Restart Numbering / Continue Numbering from Previous

These two commands toggle. The first restarts the numbering sequence for every paragraph that is selected. The second resumes the numbering sequence from the last number or letter before any break was introduced.

Use None

Removes any of the numbers that have been automatically created.

Select Next in Style

Select All in Style

The style icon button menu of the Note Styles palette

The commands of the Note style icon button menu mirror those of the top portion of the commands of the main menu: Format > Note Style.

Redefine Style from Selection

Set Custom Note Reference…

Remove Custom Note Reference

Select Next Note

Select Previous Note

Select Next in Style

Select All in Style

The gear menu

The lower right corner of the palette displays a Gear. The menu that appear when you click it is the same for all four versions of the Styles palette.

Remove Attributes Except Styles

Edit Styles…

Show Style Library

Save to Style Library…

WYSIWYG Styles palette

You can modify the display of the styles in the Styles palettes to make them WYSIWYG or not.

Nisus Writer Express generally displays your Styles palettes with the characteristics of that style so that each style’s name appears with all its character formatting. You can change this. The options are illustrated in Figure 114.

From the “” (Ellipsis, or Options menu) on the title bar of any of the Styles palettes choose the menu command:

Style Preview Mode > Plain Text to remove all formatting,

Style Preview Mode > Formatted Text to display all formatting including possible extreme height characteristics, or

Style Preview Mode > Formatted Text - Small Size to display the formatting, but maintain a similar height for all styles.

The Style Sheet view’s interface

The Style Sheet view, illustrated in Figure 117 on page 139 lists all the styles of the document in a sidebar along the left side of the window (that you can hide or reveal, minimize or enlarge (to make sure you see the styles’ full name) by dragging the vertical line that separates it from the Style Definition area). The Styles are listed in alphabetical order grouped by Character Styles followed by Paragraph Styles and then Note Styles and, finally, List Styles. You can display all styles or a sub-set of them by clicking the reveal triangle to the left of that section’s title bar, or the title bar itself. You can view two or more styles that are not contiguous by pressing as you click each style name. You can select a range of styles by pressing as you drag across the list.

Each style has its own portion of the Style Definition area. When you select a style, its controls activate in a blue rounded rectangle as illustrated in Figure 118 on page 140. The upper left area displays the style’s name and beneath that a sample of text as it would appear in the document. (You can modify either, or both, of these.)

Above the style’s rectangle the horizontal ruler appears (though you can turn this off/on). If you edit a Character Style the ruler is disabled, as the ruler can only affect Paragraph level styles.

At the bottom of the window, below the style definition area, two buttons enable you to save the active styles to a library of styles, or import an existing style from a library of styles. You can learn more about Style libraries in the section: “Maintain a Style Library” on page 148.

See the Style Sheet associated with a document

You can see (and edit) all the details of all the styles in your document, using any of the following methods.

This changes the view of your document. It momentarily (while in that view) hides the text of your document.

Choose the menu command: View > Style Sheet.

Click the Style Sheet portion of the View button on the Toolbar.

Style Sheet button (selected).png

Figure 116
The Styles Sheet portion (selected) of the View button

Choose the menu command: Gear > Edit Styles… at the bottom of any of the Styles palettes.

Choose Edit Style… from the style tag menus on right edge of the Status Bar at the bottom of the document window to display the style in which your insertion point appears.

Double-click the active style’s name in the Styles palette to display and edit the style you double-clicked.

The Style Sheet view.png

Figure 117
The Style Sheet view

The default Normal style in Style Sheet view.png

Figure 118
The default
Normal style in Style Sheet view

Beneath the sample text within the blue rounded rectangle, in clearly readable “bubbles”, are all the characteristics that make up the selected styles. You can click to select and delete any of the formats you do not want as part of the style. You can use the tools of the Character and Paragraph palettes (among others) to make the changes you want to alter the formatting of the selected style.

Below the sample text and the “bubbles” and to the left are controls you can use to

determine on what other style in the document this should style be based, as explained in the section: “Have one style inherit the formats of another” on page 141;

assign a keyboard shortcut to the style, as illustrated in Figure 119 on page 142;

determine the style automatically assigned to the next paragraph (when you press ), as explained in the section: “Determine the style of the next paragraph of your text automatically” on page 142.

Edit a style

You can edit all the details of all the styles in your document.

1. Display Style Sheet view of your document as explained in “See the Style Sheet associated with a document” on page 138.

2. Select the style (or styles) you want to modify.

Or

Double-click a style’s name in the Styles palette to display the style you double-clicked.

Choose Edit Styles… from the Gear menu in the lower left corner of the appropriate Styles palette.

Select more than one style

Press as you click each style’s name.

Press as you drag across a number of styles.

When you have more than one style selected you can only change those characteristics that they currently share. Changing any of the non-shared formats will automatically deselect those styles that do not share the property.

Modify a style

Once the Style Sheet is open and you have selected a style…

Use the tools of the Format menu or the palettes of the Writing, Formatting or Paragraph palette groups to apply the attributes you want to that style.

Select and delete any of the “bubbles” you do not want applied to the style.

Change the name of a style

Once the Style Sheet is open and you have selected a style…

1. Click in the name area of the selected style.

2. Select or delete the text there and type the name you want as illustrated in Figure 122 on page 144.

Have one style inherit the formats of another

Once the Style Sheet is open and you have selected a style…

Choose that style’s name from the Based on pop-up menu.

Depending on the style you choose, both Paragraph and Character (as well as the various Note and List) Styles are available here. However, the only style names that appear in the pop-up menu are those that are available. If Heading 3 is based on Heading 2 and Heading 2 is based on Heading 1 which is based on Title, which is based on Normal, the Normal style cannot (logically) be based on Title, Headings 1, 2, nor 3.

For example…

Normal style has the paragraph formats (listed in alphabetical order)

First Line Indent 0

Font Size 12 pt

Font Times

Left Indent 0

Line Spacing 1 lin

Paragraph Spacing After 6

Paragraph Spacing Before 0

Text Alignment Left

Text Color Black

Heading 1 style is based on Normal. To distinguish it from Normal you only need to designate

Bold

Font Size 14 pt

Font Lucida Grande

Paragraph Spacing After 0

Paragraph Spacing Before 6

All other formats will remain the same as those for Normal.

Heading 2 style is based on Heading 1. To distinguish it from Heading 1 we only want to make it a bit smaller

Font Size 13 pt

All other formats will remain the same as those for Heading 1.

You can “base” Paragraph Styles on other Paragraph Styles and have different Character Styles underlying them. You cannot base a Character Style on a Paragraph Style.

Determine the style of the next paragraph of your text automatically

Generally, when you type descriptive text, each new paragraph shares the same formatting as the one that preceded it. Headings are exceptions to this. Usually a heading is immediately followed by normal text. The styles of Nisus Writer Express take this into account. You can determine the style of the following paragraph.

1. Choose the menu command: View > Style Sheet.

2. Select the style you want to modify from the sidebar on the left.

3. Choose the style for the next paragraph from the Next Style pop-up menu.

Normal style is already set to follow the various Heading styles and the Title style.

4. Return to Draft View or Page View.

Assign a keyboard shortcut to your style as you edit it

Nisus Writer Express allows you to assign keyboard shortcuts to any command of the program. You can set your keyboard shortcuts in the Preferences as explained in “Menu Keys for Menu Commands” on page 360. However, while you are busy working on your styles, Nisus Writer Express allows you to assign the shortcuts right in the Style Sheet view.

1. Click your insertion point in the Shortcut box.

2. Type the key you want for your shortcut.

Assigning a Menu Key shortcut in the Style Sheet view.png

Figure 119
Assigning a Menu Key shortcut in the Style Sheet view

Remove a keyboard shortcut from your style

1. Click your insertion point in the Shortcut field.

2. Press .

Change the sample text that illustrates your style

The right side of the Style Sheet view has a window with a string of text. While one line of text is usually sufficient for illustrating your Title and Heading styles, for your Normal style you would probably want at least three paragraphs of text to be able to see not only the leading (line spacing) but the space allocated before and after paragraphs.

1. Click the style name to select the style you want to modify.

2. Click your insertion point in the sample text field and select all the text there (Choose the menu command: Edit > Select > Select All or press a).

3. Paste any text you have on the Clipboard or type in the text you want as illustrative.

Changing the text and paragraph formatting in Style Sheet view.png

Figure 120
Changing the text and paragraph formatting in Style Sheet
view

Quickly remove formats that define your style

Beneath the string of text on the right side of the Style Sheet view indicators appear in little “bubbles”. Each bubble represents a different format associated with that style.

1. Click the style name to select the style you want to modify.

2. Click to select the format you wish to remove.

3. Press to remove that format.

When you delete any of these formats, the style assumes the reigning format of the style upon which it is based. If it is not based on any particular style, it assumes the format set in the Format portion of your New File preferences (the Nisus New File) as illustrated in Figure 317 on page 373.

image-133.png

Figure 121
The format “bubbles” of the Style Sheet
view illustrated in Figure 120 above with “Line Spacing” selected

Add or modify formats associated with your style

1. Click the name of the Style you want to modify in the sidebar on the left of the window.

2. Make the changes you want using the appropriate menus or palettes.

Create a new style

Your writing needs may differ from those of others. You may need various kinds of numbered lists or “block-quoted” text, or sections of computer code. You can create a new style to control these or any other block of text you want to format.

1. Choose

image-134.gif the menu command: Insert > New Style > Character Style Based on Selection to create a style that inherits the character formatting of the text in which your insertion point appears.

image-135.gif the menu command: Insert > New Style > Paragraph Style Based on Selection to create a style that inherits the character and paragraph formatting of the text in which your insertion point appears.

image-136.gif the menu command: Insert > New Style > Character Style to create an entirely new style that has no relationship to the text in which your insertion point appears.

image-137.gif the menu command: Insert > New Style > Paragraph Style to create an entirely new style that has no relationship to the text in which your insertion point appears.

image-156.jpg the menu command: Insert > New Style > List Style to create an entirely new style that has no relationship to the text in which your insertion point appears.

Variants of these same commands appear if you click the Plus (+) button pop-up menu in the Styles palette.

The new paragraph style based on the selection.png

Figure 122
The new paragraph style based on the selection

2. Give the style a unique name.

3. Modify the style’s formats as explained in “Edit a style” on page 140.

Select all the text in your document with a particular style

You may have your insertion point in a string of text of a particular style and you want to assign a different style to that text. Ordinarily, if it is a character based style you would have to find and select the entire string of text by guessing where it began and ended. However Nisus Writer Express offers a special tool for doing this.

1. Click your insertion point inside the area of text the style of which you wish to select.

2. Choose

Select All in Style from the Character Style, Paragraph Style, Note Style or Lists submenu of the Format menu or

Select All in Style from the Character Style image-138.gif, Paragraph Style image-139.gif or List Style image-156-2.jpg tags on the Status Bar or 

Select All in Style from the pop-up menu that appears from the Character Style image-140.gif, Paragraph Style image-141.gif tags in the Styles palette.

This selects all text in your document which shares that style.

Select the next instance of text in a particular style

You may have your insertion point in a string of text of a particular paragraph or note style, or selected some text in a specific character style, and you want to find the next bit of text in your document that shares that style. Ordinarily, if it is a character based style you would have to find and select the entire string of text by guessing where it began and ended. However Nisus Writer Express offers a special tool for doing this.

1. If it is a character style select some of that text, or, if it is a paragraph style, click your insertion point inside the area of text the style of which you wish to select.

2. Choose the command: Select Next in Style

from the menus: Format > Character Style, Paragraph Style, Note Style or Lists

from the Character Level image-142.gif, Paragraph Level image-143.gif or List image-156-3.jpg style tag on the Status Bar…

from the Character Level image-144.gif, Paragraph Level image-145.gif or List buttons on the Toolbar.

This selects next instance of text in your document which shares that style.

Remove a style’s formats from selected text

You may have a document with styles associated with text that you no longer want. You can easily remove that Style from the text.

1. Click your insertion point inside any area of text of the Paragraph Level Style which you wish to remove.

2. Choose

the menu command: Format > Paragraph Style > Remove Paragraph Styles,
or

Remove Style from the Paragraph Level image-146.gif style tag on the Statusbar of the document window, or

Remove Paragraph Styles from the image-147.gif pop-up menu in the Paragraph Styles palette.

from the Paragraph Level image-148.gif Styles button on the Toolbar.

3. If it is a Character Level style, select the range of text from which you wish to remove the style and choose

the menu command: Format > Character Style > Remove Character Styles, or

Remove Style from the Character Level image-149.gif style tag on the Status Bar or

Remove Character Styles from the image-150.gif pop-up menu in the Character Styles palette.

from the Character Level image-151.gif Styles button on the Toolbar.

Remove a character format from your text

Removing formats from your text is easy.

1. Click your insertion point in the area of text which has the format you wish to remove.

2. Choose Select Range or Select All from the Character Formatting tag on the Status Bar.

3. Choose Remove Font from the Character Formatting tag on the Status Bar.

When you remove these character formats, any underlying paragraph style characteristics appear. If no paragraph style is assigned to the text, whatever you have set in the Format portion of the New File preferences, as illustrated in Figure 317 on page 373 will appear.

image-152.png

Figure 123
The Select/Remove Character Formatting tag on the Status Bar

Remove a style from your document

You may have received a document with styles that do not match the way in which you do your work. You can remove all vestiges of that style from your document (both the style’s name and the fact that it is applied to text in your document).

1. Choose the menu command: View > Style Sheet.

2. Click the name of the style you wish to remove.

Be sure not to click inside the style’s name or the sample text area or on any of the characteristics that make up the style.

3. Either:

Press , or

Click the Minus (-) button at the bottom of the list of styles in the lower left area of the document window.

If your style is not applied to any text you will see the following dialog:

image-153.png

Figure 124
The “style is not currently used” dialog

If, however, your style is applied to text you will see the following dialog, which states that “This style is currently used in the document. Deleting it may change the formatting of your document.”:

image-154.png

Figure 125
The “style is currently used” dialog

You should consider carefully how you want to proceed.

Resolve conflicts between styles

You can copy and paste text with its associated styles from one document to another.

Depending on what you have set in your General preferences of Nisus Writer Express (as explained in “Set “Defaults” for the Application” on page 350) you have a variety of choices. The default is set to Always ask me what to do.

If a Style with the same name already exists in a new document, but it has different formatting, Nisus Writer Express presents a sheet that offers a series of choices.

image-155.png

Figure 126
The Style conflict sheet

As explained in the dialog sheet that appears, the options have these effects

Use Existing Styles

The document’s existing styles will be used for the pasted text.

Add Pasted Styles

The styles in the pasted text will be renamed (by appending a numeral in sequence) and added to the styles of the document.

If you are secure in your decisions you can check:

Do not ask again for this document as long as it remains open.

If you are not sure what you want to do:

Click Cancel.

Maintain a Style Library

As explained in the beginning of this section on pages 132 and 133, Nisus Writer Express displays all of the styles that exist in a particular document in the Style Sheet view and in the Styles palettes as well as on the Character Style, Paragraph Style and Note Style submenus of the Format menu. The Nisus New File comes with a variety of styles built in, as explained on 133. You can add as many styles as you want to the Nisus New File so that all your favorite styles are always available in each new document you open, but that might make it hard to find just the few styles you regularly use.

The solution is to create a number of files, each containing styles specific to one particular kind of project and save them in the Style Library folder of the Document Manager. You can then import any styles you want on an as-needed basis into your current document.

The Document Manager is described in depth on pages 77 - 93.

Create a style library

Creating a style library is simple. There are a variety of methods.

Empty Style Library.png

Figure 127
The Document Manager showing the Style Library window with nothing in it

Import styles from an existing file

1. Open a document that has styles you want to add to a Style library.

2. Choose the menu command: View > Style Sheet.

3. Select the style(s) you want to add to the Style Library from the list in the Styles sidebar on the left side of the document window.

4. Either

choose the menu command: Gear > Save to Style Library… at the bottom of the styles list in Style Sheet view, or,

click Save to Style Library… in the style previews area of the Style Sheet view.

7C154016-D6F3-45BE-9375-BC05B585A588.png

Figure 128
The Save to Style Library… button in the define styles area of the Style Sheet view

5. A sheet appears. Type the name you want to use in the Add styles to a new style collection field.

7C2FFB1C-9F88-4491-9F7B-F854A6BE6F84.png

Figure 129
The Add styles to a new style collection sheet

6. Click Save.

The Document Manager with a Style Collection and its associated styles.png

Figure 130
The Document Manager with a Style Collection and its associated styles

Note that even though only Heading D was selected in the Styles List and saved to the Style Library, because it is “based on” Heading C which is based on Heading B, etc. all the based on styles are also added to the library.

Save a file with styles you want to the Style Library folder of the Document Manager

You may already have created a document that has a collection of styles you want to add to your Style Library.

1. Open a document that has styles you want to add to a style library.

2. Choose Style Library from

the menu command: File > Save in Document Manager to save the file in the Style Library;

the menu command: File > Save As in Document Manager… to save a copy of the file (with, perhaps a new name) in the Style Library;

the menu command: File > Move to Document Manager to actually move the file from its current location into the Style Library;

the menu command: File > Add to Document Manager to place an alias that points to the file into the Style Library;

Saving a file to the Style Library of the Document Manager.png

Figure 131
Saving a file to
the Style Library of the Document Manager

The file and its styles appear in the Style Library portion of the Document Manager.

A document with styles saved to the Style Library of the Document Manager.png

Figure 132
A document with styles saved to the Style Library of the Document Manager

Add styles to an existing Style Library file

Once you have created a Style Collection in your Style Library, you can add styles to it.

1. Open a document that has styles you want to add to a style library.

2. Choose the menu command: View > Style Sheet.

3. Select the style(s) you want to add to the Style Library from the list in the Styles sidebar on the left side of the document window.

4. Either

choose the menu command: Gear > Save to Style Library… at the bottom of the styles list in Style Sheet view, or,

click Save to Style Library… in the style previews area of the Style Sheet view.

Selecting a style to add to a Style Collection.png

Figure 133
Selecting a style to add to a Style Collection

5. A sheet appears. Click Add styles to an existing style collection.

6. If you have more than one collection be sure to select the appropriate collection.

Selecting a Style Collection to which to add styles.png

Figure 134
Selecting a Style Collection to which to add styles

7. Click Save.

A Style Collection with added styles.png

Figure 135
A Style Collection with added styles

Your new styles appear in the selected Style Collection.

Save specific styles from an existing file to a Style Collection

You may already have created a document that has a collection of styles you want to add to your Style Library.

1. Open a document that has styles you want to add to a style library.

2. Either choose Save to Style Library…

from the Gear menu at the bottom of the Styles palette, or,

from the menu command: Insert > New Style.

A sheet appears from which you can choose the styles to save to the style library.

3. Select the styles you want to add and click Save.

Choosing styles to add to a Style Collection with the Styles palette open.png

Figure 136
Choosing styles to add to a Style Collection with the Styles palette open

A variant of the sheet illustrated in Figure 122 on 144 appears.

4. Select the style collection to which you want to add the styles and click Save.

Selecting a particular Style Collection to which to add styles.png

Figure 137
Selecting a particular Style Collection to which to add styles

Your styles are added to the collection and ready for you to use in additional documents as illustrated in Figure 138.

Multiple style collections with many styles.png

Figure 138
Multiple style collections with many styles

Use styles saved in a Style Library

Once you have your Style Library set up you can easily take styles from it to use in different documents.

Suppose that you are busy working on a new document that has a minimum number of styles in it. You come to a point where you realize that you need a style that you have saved to your style library.

Import a style the formats of which you know

1. Choose the menu command: Insert > New Style > Import from Style Library….

A sheet appears that lists all the styles available in the various Style Collections in your Style Library.

2. Scroll through the list and check the styles you want to import.

3. Click Import.

The style now appears in the Styles palette of the active document. You can select text and apply the style.

Import a style the formats of which you do not know

As an alternate method, especially if you do not remember the various formats of the different styles, you can:

1. Either…

Choose the menu command: Window > Document Manager (and select Style Library in the sidebar on the left) or

Choose the menu command: Gear > Show Style Library of the Character or Paragraph Styles palettes, or

Choose the menu command: Insert > New Style > Show Style Library.

This opens the Document Manager with the Style Library selected in the sidebar.

2. Select any of the Style Collections you have in your Style Library from the top pane on the right. The associated styles appear (in their formats) in the bottom pane.

3. Drag the style(s) you want from the list at the bottom into any open window.

The style now appears in the appropriate (Paragraph or Character) Styles palette (depending on what kind of style it is) of the active document. You can select text and apply the style.

Open a Style Collection to copy text with style for pasting in another document

If the style’s name displayed in its own formats does not give you enough of an idea of how the style appears, you can also open a particular Style Collection directly and copy styled text from it.

1. Choose the style collection you want from the menu File > Open from Document Manager > Style Library.

This opens the actual Nisus Writer Express document with the style in it. If you have text displaying that style in the document you can see how it appears as illustrated in Figure 131 on page 152.

2. Copy some text in the style(s) you want to have in the new document.

3. Paste the text into your new document.

The style now appears in the Styles palette of the active document. You can select text and apply the style.

Once styles are copied from the Style Library and used in another document they lose all connection to the original Style Library file. If you make changes to the style in the Style Library file, these changes do not appear in any of the files to which the style has been imported or copied.


Previous Chapter
Format Characters
<<  index  >>
 
Next Chapter
Set Up a Document’s Page