Wrong icon for Nisus files

Everything related to our flagship word processor.
Post Reply
ameddo
Posts: 11
Joined: 2004-07-31 15:18:44

Wrong icon for Nisus files

Post by ameddo »

My Nisus files always show in the Finder with a Microsoft Word icon — though I don't save my files in .doc or docx. I tried several times to change that in 'Get Info', but the problem persists.

Bob Stern
Posts: 155
Joined: 2006-03-12 12:32:47

Re: Wrong icon for Nisus files

Post by Bob Stern »

2 things to try:

1. Restart the Mac in safe mode. To do this, after a restart hold down the Shift key until the Apple icon appears. After it finishes booting, restart again normally.

2. Rebuild the launch services database. You can do this without using Terminal using the donation-ware program Onyx (which also can perform many other maintenance tasks):
https://www.titanium-software.fr/en/onyx.html

ameddo
Posts: 11
Joined: 2004-07-31 15:18:44

Re: Wrong icon for Nisus files

Post by ameddo »

Thank you, Bob. The problem is almost fixed after I used both methods. However, the Templates (.dot) still carry the Microsoft Word icons. When I click on them they open with Word not Nisus.

martin
Official Nisus Person
Posts: 4738
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Wrong icon for Nisus files

Post by martin »

ameddo wrote:
2020-07-04 06:01:24
However, the Templates (.dot) still carry the Microsoft Word icons. When I click on them they open with Word not Nisus.
To change what app opens your .dot files you'll have to adjust your "Get Info" settings in the Finder, like you did with your other formats. Please see this FAQ on changing a file format's default app. The FAQ talks about .rtf files opening in TextEdit, but you can follow the same steps for other file formats like .dot files.

Once you update your Finder settings so .dot files are set open in Nisus Writer, the icons will hopefully also change. I say "hopefully" because this isn't under our control. As you saw with your other files, this is something Apple controls and it doesn't always behave as it should.

Post Reply