Courier changes double dash to an em-dash.

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
MarioMilosevic
Posts: 10
Joined: 2008-10-14 12:50:18

Courier changes double dash to an em-dash.

Post by MarioMilosevic »

Anyone know how to stop the Courier font from converting two consecutive dashes into an em-dash? I want to keep the two dashes as they are, but I can't find a place to tell Nisus to leave the two dashes alone. This doesn't happen in any other fonts I use. Only in Courier. Help!

martin
Official Nisus Person
Posts: 4738
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Courier changes double dash to an em-dash.

Post by martin »

I wasn't able to observe this behavior with either Courier or Courier New. What version of OSX are you using?

One thing to check: did you ever add a QuickFix substitution for some language you are working in? Perhaps it's the language attribute and not the font that's triggering the change.

MarioMilosevic
Posts: 10
Joined: 2008-10-14 12:50:18

Re: Courier changes double dash to an em-dash.

Post by MarioMilosevic »

I'm using 10.5.8.

I looked in quickfix. The only language I ever use is English (U.S.) I never added a quickfix substitution for this.

So I'm still at a loss as to what to do.

martin
Official Nisus Person
Posts: 4738
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Courier changes double dash to an em-dash.

Post by martin »

Could you send us an example document using the menu Help > Send Feedback? It may not help us discover the cause of the unwanted change, but at least I'll be sure about what exactly we're dealing with.

MarioMilosevic
Posts: 10
Joined: 2008-10-14 12:50:18

Re: Courier changes double dash to an em-dash.

Post by MarioMilosevic »

I sent the report. Thanks.

Mario

martin
Official Nisus Person
Posts: 4738
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Courier changes double dash to an em-dash.

Post by martin »

In case anyone runs into a similar problem: this ended up being a font problem. Reinstalling Courier fixed the issue for Mario.

Post Reply