Underlined Hebrew text - a bug?

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Underlined Hebrew text - a bug?

Post by Ruchama »

Has anyone noticed the following:

if a hebrew text is typed underlined, followed by numbers, which are supposed to be underlined as well, then Return (new line)- the underline under the numbers disappears! reselecting-re-underlining does not help, it stays un-underlined.
does this happen in other languages as well?

is there any way around it?

thanks

martin
Official Nisus Person
Posts: 4775
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin »

This seems to be a bug with the underline drawing code. I think it is getting confused by the directionality of the paragraph versus that of the digits. The work around is to insert reverse direction spaces around the digits (one before the group of digits and one afterwards). Just use the menu Insert > Reverse Direction Space.

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Post by Ruchama »

Hi Martin,

Thanks again for your quick reply.

Following your advice I tried to use 'Reverse direction space' but I could not see that it helps. while the text is selected I can see the underline (with or without the spaces), but when moving away it disappears. maybe I missed something there.


Should I report this bug through the 'send feedback' command? or is it enough that it is reported here.


By the way, the macros work just fine, the only limitation I have noticed is that when the text is printed (through a macro) at the beginning of a line, it always changes the alignment of the paragraph to the left (eventhough the template file is right-aligned), and it forces me to insert 'align right' into the macro. That, in turn, is not 100% convenient when paragraph is supposed to be 'centered'.. But- we can't have it all, can we?

(is there a way to 'read' into a macro the current paragraph's settings?)

Ruchama

martin
Official Nisus Person
Posts: 4775
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin »

Glad to help...
Ruchama wrote:Following your advice I tried to use 'Reverse direction space' but I could not see that it helps. while the text is selected I can see the underline (with or without the spaces), but when moving away it disappears. maybe I missed something there.
Hm, try this file and see how it looks. For me the first line shows the problem, while the second line has the underline drawing properly.
Should I report this bug through the 'send feedback' command? or is it enough that it is reported here.
Just reporting it here is enough for this particular bug, thank you for asking.
(is there a way to 'read' into a macro the current paragraph's settings?)
I'm afraid not, sorry.

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Post by Ruchama »

Martin,

It seems you have the magic touch... I can see in your file the correct view and I see a straight arrow reflecting the spaces. I even managed to type another sentence with the ocrrect view. However, openning another file (checking the 'show invisible') shows me a currly arrow (which I don't know its meaning) and does not show the underline.

is there an explanantion? what am I doing wrong?
thanks

martin
Official Nisus Person
Posts: 4775
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin »

Ruchama, could you send an example file to expressfeedback@nisus.com? I'll take a look and see what is going on.

DavidK
Posts: 72
Joined: 2004-10-26 15:35:19
Location: Grand Rapids, MI

Post by DavidK »

martin wrote: Hm, try this file and see how it looks. For me the first line shows the problem, while the second line has the underline drawing properly.
Martin - When I looked at the file, neither in the first nor in the 2nd example were the numbers underlined.

David

Post Reply