LinkBack

Have a problem? A question? This is the place for answers from other Express users.
User avatar
Patrick J
Posts: 124
Joined: 2006-06-16 16:17:50
Location: Brighton & Hove, UK
Contact:

LinkBack

Post by Patrick J »

I realised that I have two LinkBack applications, Nisus Writer Express and Intaglio. With Intaglio I found I have to check a box in preferences to enable LinkBack.

Gosh, it works!

What a splendid thing it is as well. I was a great fan of OpenDoc but the real challenge with OpenDoc was getting it to work :(

After the OpenDoc experience I wasn't really expecting LinkBack to just work like that but indeed it seems to!

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

totally confused

Post by gemboy27 »

I have Nisus Writer Express 2.7
OminiOutliner 3.6 (upgraded from iMac bundle)
Image Tricks

I can not figure out how to make the linkback work


What am I missing?

Thanks
Gem*Boy



G5 intel 10.4.7
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Re: totally confused

Post by Mark XM »

gemboy27 wrote:I have Nisus Writer Express 2.7
OminiOutliner 3.6 (upgraded from iMac bundle)
Image Tricks
I can not figure out how to make the linkback work
What am I missing?
Thanks
Gem*Boy
G5 intel 10.4.7
Both NWE and Outlook Express are LinkBack clients, that is to say that they will accept pasted items from a LinkBack source application, but they are not sources themselves. OmniGroup say they are planning to make OmniOutliner a link back source in a future version.
I don't know about Image Tricks. OmniGraffle (Fantastic App) is a LinkBack source which works brilliantly with both OmniOutliner and NWE. Just copy what you want and paste it into the target app.
I guess you need to go to the LinkBack website to find out what apps are LinkBack sources. I know Chartsmith is, but not of any others, as I have had no need for them. :)
Mark
TiBook 400/640 10.4.7 :cry:

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

??

Post by gemboy27 »

been http://www.linkbackproject.org/ (there), but it just doesn't make sense to me...

I understand 'client' and 'server'

I just don't see where the various 'clicks' are to make the linkback work

Gem*Boy
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Re: Using LinkBack

Post by Mark XM »

gemboy27 wrote:been http://www.linkbackproject.org/ (there), but it just doesn't make sense to me...

I understand 'client' and 'server'

I just don't see where the various 'clicks' are to make the linkback work

Gem*Boy
For instance: if you create a graphic in OmniGraffle; select all and copy, open an NWE document and paste--you must use copy and paste. You now have your graphic in NWE.
Close OmniGraffle if you want.
Double-click on the graphic in your NWE document and OG will open/come to the front with the graphic on a new page titled "Linkback item from Nisus Writer Express" which you can edit as normal in OG; make some changes, save and then go to NWE. The graphic in your NWE document has those changes.
The same process works between OmniGraffle and OmniOutliner.
You cannot work the other way. You cannot copy a block of text in NWE, paste it into either Omni application, double-click on it and re-edit it in NWE.
The other app you mentioned in your first message is not one I know, so I don't know whether it will act as a LinkBack server.
Mark

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

thanks

Post by gemboy27 »

O I know how they work, I just can't make it work for me.....

thanks
Gem*Boy
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Re: thanks

Post by Mark XM »

gemboy27 wrote:O I know how they work, I just can't make it work for me.....

thanks
Gem*Boy
I've just had a look at the Image Tricks site and the LinkBack site. Image Tricks apparently uses LinkBack, but I get the impression that it will only work in conjunction with another graphics app like the others Belight produces. I've downloaded it and will give it a whirl when I have a moment.
Mark

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

On the pages

Post by gemboy27 »

on the Keynote (iWorks) they show that Sketch will work, but I can't get it to work with NWE, and the version I have of of Keynote(3) doesn't have a linkback pug in for it (yet)

maybe I will try sketch to imagetricks

gem
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

must have the right program

Post by gemboy27 »

Okay... I got a linkback from NWE 2.7 to Sketch

one trick that I didn't notice before is when you double click on the image in NWE and it takes you to the linkback (Sketch image) and you change it, you have to save THEN it changes in the NWE file.

of course I want it to work with OminiOutliner...but such is life.

take care
Gem
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Re: must have the right program

Post by Mark XM »

gemboy27 wrote:Okay... I got a linkback from NWE 2.7 to Sketch

one trick that I didn't notice before is when you double click on the image in NWE and it takes you to the linkback (Sketch image) and you change it, you have to save THEN it changes in the NWE file.

of course I want it to work with OminiOutliner...but such is life.

take care
Gem
Yes, you have to save the changes--see my previous post. If it is working with NWE, it should be working with OO ... when you've pasted the image into OO, you have to click the disclosure triangle to see it--when it is pasted it just gives you a rounded thing with a name such as "linkback item". But if you mouse over it there is a triangle in the left of that area, click on that and the graphic is displayed.
By the way, I've just tried Image Tricks ... it crashes every time I double click the image in NWE. I copied the contents of the Apple Crash Report and have sent it to both Nisus and BeLight. I think there must be something wrong at the BeLight end, as I have only had a good experience with NWE and LinkBack.
Mark

New edit.

I use Keynote 2, again with OmniGraffle and it has always worked like a dream. I don't have Keynote 3 ... When I get my new MacBook Pro, I'm wondering whether I should even bother to get the new version of iWork.

Mark

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

stay with two

Post by gemboy27 »

on the KeyNote page they say there isn't a plug in for Key3, but is coming
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

gemboy27
Posts: 353
Joined: 2003-09-30 21:33:58
Contact:

one more thing

Post by gemboy27 »

Is there a way to make NWE go into OmniOraphic.... I can't see importing OO into NWE, butt using the wordprocessing capablities of NWE would be helpful -- to me.

It's not that there isn't good word processing in OO, just I like NWE better -- ;-)

good evening
Gem*Boy
I have never let my schooling interfere with my education/Mark Twain (1835-1910)

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Re: one more thing

Post by Mark XM »

gemboy27 wrote:Is there a way to make NWE go into OmniOraphic.... I can't see importing OO into NWE, butt using the wordprocessing capablities of NWE would be helpful -- to me.

It's not that there isn't good word processing in OO, just I like NWE better -- ;-)

good evening
Gem*Boy
Currently no. That is to say you could write in NWE then cut and paste into OmniOutliner--but you'd really want that to go the other way round ... outline to expanded editing ... mind you there are people who seem to be writing books in OmniOutliner!--but you'd have to do it separately for each paragraph into a separate row, unless you wanted the whole thing in a single row.
For OmniGraffle, again, you'd have to paste it into a text block.
Any further editing would have to be done in OO or OG. NWE is not a LinkBack server.
OO is a great app with masses of potential, but it is an outliner, not a word processor, page make-up app, spreadsheet or whatever ... mind you, you can use it as a very basic mini-spreadsheet, just like you could write a book in it if you wanted to! :D

Mark

philippe99
Posts: 26
Joined: 2004-07-28 01:27:49
Location: Tilff, Belgium
Contact:

Post by philippe99 »

In my case -Intaglio and NWX-, the Linkback system as described above works fine only if the Intaglio app is running.
Otherwise, when I double-clik on a Intaglio image in a NWX document, the System sends me "Cannot find Intaglio.. {...} Be sure Intaglio is your Applications folder or Get the application"

All my applications are in the Applications main folder (not in a sub-folder)

???
Philippe

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Post by Mark XM »

philippe99 wrote:In my case -Intaglio and NWX-, the Linkback system as described above works fine only if the Intaglio app is running.
Otherwise, when I double-clik on a Intaglio image in a NWX document, the System sends me "Cannot find Intaglio.. {...} Be sure Intaglio is your Applications folder or Get the application"

All my applications are in the Applications main folder (not in a sub-folder)

???
Philippe
That must be a problem somewhere in your system, not specifically to do with LinkBack or its implementation in either of the apps in question.
I know that OmniGroup hasn't yet solved a similar kind of problem with their "clippings service", where it will post a message saying "OmniOutliner cannot be found" the first time you use the service after a shut-down, even though both the app and the clippings file are opened.
I don't know what the answer is, but my immediate gut feeling is to say, try repairing the permissions on your system disk (Use "Disk Utility") perhaps even start up from your CD-rom/DVD and try checking the system disk completely for errors and repairing it if there are any.
Other point ... I am using an aged TiBook 400 ... if you are using a new Intel-based Mac, it is possible that there is an issue there which I don't experience. Also I don't have "Intaglio" to try.

HTH
Mark

Post Reply