UK English for speller?

Have a problem? A question? This is the place for answers from other Express users.
Post Reply
writemoves
Posts: 3
Joined: 2006-05-23 10:23:28

UK English for speller?

Post by writemoves »

Hi. I am new to Nissus and trialling the Express product. As a Brit, I badly need a UK spellchecker. Does one exist? Apologies if I have missed something. I am British, after all. :)

User avatar
martin
Official Nisus Person
Posts: 4925
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin »

OSX ships with a UK spellchecker built-in to the system. To have Nisus Writer Express use this spellchecker, just mark your documents in the English (British) language. You may also want to adjust your New Document preferences so this is the default language.

User avatar
martin
Official Nisus Person
Posts: 4925
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin »

Also, I should mention this, since it seems to surprise people: language is an attribute of text, just like font or color. This means you can have parts of your document in British English and other parts in US English, or German, or whatever.

This also means that documents you receive (or bits of text you copy-paste from other applications) may have a language set that is different than the one you chose in your preferences.

writemoves
Posts: 3
Joined: 2006-05-23 10:23:28

Post by writemoves »

Thanks Martin, but not sure how to set to British. When I look at the language tab in Nissus no British appears.

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Post by cchapin »

It should appear in the pop-up list as "English (British)." If it doesn't, open Preferences, click the languages tab, click the More button, and put a check next to "English (British)."

--Craig

User avatar
martin
Official Nisus Person
Posts: 4925
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Post by martin »

writemoves wrote:Thanks Martin, but not sure how to set to British. When I look at the language tab in Nissus no British appears.
Craig is correct, click the "More..." button and check mark English (British).

After that, to change the default language for new files, click the New Document preference pane, then the Format tab. Now you should be able to select English (British) from the Language popup button.

To apply languages in an existing document: select the text you want to change and use the menu Format > Language or the Language palette.

writemoves
Posts: 3
Joined: 2006-05-23 10:23:28

Post by writemoves »

Excellent. It works. Thanks for your help, guys. :D

garner
Posts: 6
Joined: 2005-06-06 13:54:34

Post by garner »

On a similar note, being a Brit I'd like to be able to have all my new documents default to proper English rather than English (US). And when I paste text from a web page or any other document with language attributes, I'd like Nisus to ignore them and assume they're written in real English. After all, living in this country I'm never likely to want to misspell colour, catalogue, etc.

So I guess what I'm asking is, can I completely and permanently remove English (US) from the list of languages?

User avatar
Patrick J
Posts: 124
Joined: 2006-06-16 16:17:50
Location: Brighton & Hove, UK
Contact:

Post by Patrick J »

Hi Garner

I'm from the UK as well but it I feel it is a mistake to believe that UK English is "proper English" or that it is "real English". It is no more "proper" or "real" than US English.

English like all languages has developed in different ways in different parts of the globe and one form is not more legitimate than another.

I hope you get an answer to your question. As has been mentioned language is applied to text like a style, like bold is applied so I don't know if you are going to be able to set a program to automatically convert pasted text from US English to UK English. It is the same as requesting that a program will resist a style such as italic but accept all other styles.

I find that simply putting a preference for English (British) in the International Panel will mean that English (British) is the "default" language and that is fine by me.

Mark XM
Posts: 51
Joined: 2003-01-23 18:54:50
Location: Xiamen, China

Post by Mark XM »

garner wrote:On a similar note, being a Brit I'd like to be able to have all my new documents default to proper English rather than English (US). And when I paste text from a web page or any other document with language attributes, I'd like Nisus to ignore them and assume they're written in real English. After all, living in this country I'm never likely to want to misspell colour, catalogue, etc.

So I guess what I'm asking is, can I completely and permanently remove English (US) from the list of languages?
I am in China and get a lot of documents written under Chinese Windows/Word, which although they purport to be in English are actually tagged as Chinese, which means that if I try to edit them straight off, my edits appear in Chinese! (Furthermore, basically the Chinese in general are hardly aware of the existence of Apple--when I was trying to find a bluetooth thingie to work with my aged TiBook and a PC card wasn't recognised, the "expert" simply suggested I install Windows instead of OS-X!-- ... they don't know that there are alternative browsers to IE, furthermore Britain hardly exists and US English is the only player on the block!)
The quickest ways I have found (currently) to solve this problem are (a) set Nisus New File to British English--in spite of the computer running international English, it is disturbing to see the language palette in Nisus registering US English when no file is open!--and simply copy and paste into that telling Nisus to preserve existing styles; (b) having put "English (British)" in the languages palette, I have set key strokes <ctrl-cmd b> for British and <ctrl-cmd h> for Chinese, so can select all or only sections and then convert to whichever I want at the stroke of a key ... keyboard and font are set to follow the language choice.
Also edit the Nisus New File styles to make sure each paragraph style is in British English ... even at that point you may have a default US English, in spite of the other settings.

Mark

Post Reply