Singing the missing sigma blues.

Have a problem? A question? This is the place for answers from other Express users.
MikeKazlow
Posts: 34
Joined: 2004-12-30 12:54:30

Singing the missing sigma blues.

Post by MikeKazlow » 2005-09-29 19:00:53

I created a blank document using Nisus Writer 2.5 under Tiger 10.4.2. I typed the single letter s formatted with the Symbol font. No sigma appears on the screen just the letter s. When printed the letter s appears. When the document is saved as an rtf and opened in Word, a sigma appears.

midwinter
Posts: 333
Joined: 2004-09-09 18:07:11
Location: Utah
Contact:

Post by midwinter » 2005-09-29 19:29:45

Is this "?" the symbol? If it is, try pressing alt+W.

MikeKazlow
Posts: 34
Joined: 2004-12-30 12:54:30

Post by MikeKazlow » 2005-09-30 07:19:23

No, the sigma is the greek lowercase s. In fact none of the Symbol fonts characters seem to be working. Not for the Apple supplied Symbol font nor the Euclid Symbol font are working properly. However, my Mathematical Pi font works fine.

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Post by cchapin » 2005-09-30 08:05:36

I'm not sure how you like to work, but see if this helps.

Option 1 (for typing the occasional Greek character)

Open the Character Palette. With View set to Roman and the "by Category" tab selected, choose Greek in the list on the left. Click the character that you want. If you want to use a particular font, click the flippy triangle to reveal Font Variation and make your selection there. If you use that character frequently, add it to Favorites. Click the Insert button.

Option 2 (for typing words, sentences, or whole documents in Greek)

1. Open Nisus Writer Express's Preferences window; select Languages; click the More button; scroll down and check Greek; check Switch keyboard layout when language changes (if not already checked).

2. Open OS X's System Preferences; click International; click Input Menu; scroll down and check Greek; check Show input menu in menu bar.

3. In your document, switch to Greek input via the Format > Language menu or via the Language palette; if the input method/keyboard/flag menulet in the menu bar doesn't change to show a Greek flag, click it and select Greek.

4. Type. If you need typing assistance, use the flag menulet to show the Keyboard Viewer.

There's some discussion on this topic here.

--Craig

rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Post by rmark » 2005-09-30 09:13:35

So, Craig beat me to it. His solutions are good. I prefer (on the assumption that you "write in Math" regularly) to set up a language called "Math" in the Nisus Writer Express Languages Preferences.

You can learn about "writing in multiple languages" in the section of the Online help of that title.
Write On!
Mark Hurvitz
Nisus Software Inc.

MikeKazlow
Posts: 34
Joined: 2004-12-30 12:54:30

Post by MikeKazlow » 2005-09-30 16:16:23

These work arounds are not workable solutions when one needs to work with people that write Mathematics using Word (of various versions and various platforms) and other programs that generate rtf files. The symbol font should work as the symbol font always has. This is a bug that needs fixing, not work arounds.

rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Post by rmark » 2005-10-03 09:41:18

Dear Mike,

These are not "work arounds". This is the way it is done.

Both Nisus Writer Express and OS X in general use Unicode, and these simply don't work the way you suggest. If you type the 's' character Nisus Writer Express (and other Unicode compliant OS X applications such as Apple Computers' own TextEdit) display that character as an 's' regardless of what font it's displayed in.

OS X handles this by defaulting to Lucida Grande if the chosen font doesn't have a symbol for the character. So if you want a sigma, you have to enter a sigma character, not an 's'.
Write On!
Mark Hurvitz
Nisus Software Inc.

Ryan
Posts: 211
Joined: 2005-01-31 14:36:45
Location: Portland, OR
Contact:

Post by Ryan » 2005-10-03 12:16:46

So it seems that Word does it incorrectly. Shocking.

rmark
Official Nisus Person
Posts: 428
Joined: 2003-02-11 10:49:05
Location: Solana Beach, CA
Contact:

Post by rmark » 2005-10-03 12:22:48

Microsoft Word is not Cocoa based, Unicode, OS X application. It's not so much that word does it "incorrectly", as it does it in an antiquated manner.
Write On!
Mark Hurvitz
Nisus Software Inc.

rgball99
Posts: 2
Joined: 2005-10-04 09:20:59

Post by rgball99 » 2005-10-04 09:25:11

>>
Option 1 (for typing the occasional Greek character)

Open the Character Palette. With View set to Roman and the "by Category" tab selected, choose Greek in the list on the left. Click the character that you want. If you want to use a particular font, click the flippy triangle to reveal Font Variation and make your selection there. If you use that character frequently, add it to Favorites. Click the Insert button.
>>

Is this just for 10.4.x systems? I don't see any of the Character Palette options in 10.3.9.

Rich

cchapin
Posts: 419
Joined: 2004-02-25 18:28:40
Location: Maryland, USA

Post by cchapin » 2005-10-04 10:56:39

Sorry I wasn't more specific, Rich. The character palette is available in 10.3.9. However, access to it might appear in different places. I'm not sure why.

First look for "Special Characters" in Nisus Writer Express's Edit menu. (The shortcut on my Mac is option-command-T.)

If you don't find it there, you can access it through the Input menulet in the menu bar. It probably looks like a flag, but can take other forms. If the menulet is not there, you can display it by opening System Preferences, choosing International, then the Input Menu tab. Make sure there are checks next to Character Palette and "Show input menu in menu bar."

--Craig

rgball99
Posts: 2
Joined: 2005-10-04 09:20:59

Post by rgball99 » 2005-10-04 11:18:36

Thanks! That did it.

Rich

MikeKazlow
Posts: 34
Joined: 2004-12-30 12:54:30

Post by MikeKazlow » 2005-10-05 06:05:50

rmark wrote:Microsoft Word is not Cocoa based, Unicode, OS X application. It's not so much that word does it "incorrectly", as it does it in an antiquated manner.
No. The problem is you are using Apple's technology and I think Apple is doing it wrong. InDesign is unicode aware and has no problem with the Symbol font.

If Apple's and your "modern" method of handling unicode makes all existing documents that use the symbol font and possibly other pi fonts display incorrectly, I'll take Adobe and Microsoft's implementation any day. I'll add that the Mathematical Pi font does not have these same problems as the Symbol font does. It would seem to me that the modern method should screw up all pi fonts equally.

MikeKazlow
Posts: 34
Joined: 2004-12-30 12:54:30

Post by MikeKazlow » 2005-10-06 09:01:09

I posted on the Adobe User to User forum. Thomas Phinney of Adobe Systems responded and does say that the method Apple and Nisus is using is technically correct from a unicode point of view. However, they special case the Symbol font so that these problems don't arise. To conserve 20 years of mathematical documents and not to have to retype them all, I do prefer the Adobe/Microsoft way of handling this issue.

dshan
Posts: 334
Joined: 2003-11-21 19:25:28
Location: Sydney, Australia

Happy Sigma Days

Post by dshan » 2005-10-06 15:48:31

MikeKazlow wrote:I posted on the Adobe User to User forum. Thomas Phinney of Adobe Systems responded and does say that the method Apple and Nisus is using is technically correct from a unicode point of view. However, they special case the Symbol font so that these problems don't arise. To conserve 20 years of mathematical documents and not to have to retype them all, I do prefer the Adobe/Microsoft way of handling this issue.
You shouldn't need to retype anything. Sigmas entered into NWX via the character palette (when font is set to Symbol) are represented in the rtf file as "s" which should ensure compatibility with old-style apps like MS Word.

An actual "s" entered via the keyboard when Symbol is the active font is represented as "\u115" (the decimal unicode value of an "s", 0x73) in the rtf file, which from your report MS Word also seems to translate as a sigma (not having Word to test with I tried reading this with AbiWord 2.4 - it just ignored the "\u115" char and displayed explicitly entered sigmas correctly. Text Edit worked like NWX and displayed it as an "s" while explicit sigmas displayed as sigmas).

Sigmas entered into NWX via the character palette when the font is other than Symbol show up in the rtf file as "\u963" which is, not surprisingly, the decimal unicode value for the sigma character (0x3c3). I've no idea how Word would handle that...

As to entering Symbol font chars via the keyboard in OS X - I found references in Apple's help files/tech lib to Symbol and Dingbats keyboard layouts that came with OS X 10.0->10.1.5 but were replaced later by the character palette input method. You could maybe find these layouts from old systems/disks and see if they still work, or make your own Symbol KB layout using a utility such as Keyboard Builder from Splinter Works. Then when you want to enter Symbol chars in NWX (or other Apple-compliant unicode apps) set font to Symbol and keyboard layout to "Symbol" and everything works like the Good Old Days.

Post Reply