Page 1 of 1

Can't sync documents in iCloud

Posted: 2020-02-23 12:35:02
by jconery
I just upgraded my Macs to macOS 10.15 (Catalina) and it seems I've lost the ability to have open documents kept in sync. I created a document on machine A, saved it in an iCloud folder, and then opened it on machine B. As soon as I open it, machine A no longer lets me change the document -- if I add text I either see "document could not be autosaved" or, when I use File > Save, an error message that says "document can't be saved".

I have similar issues when the document is not in iCloud, but in a directory that is synced with other methods. Documents used to keep in sync, but not since the OS upgrade.

Using Nisus Writer Express 4.0 on macOS 10.15.3 on a MacBook Pro and an iMac.

Re: Can't sync documents in iCloud

Posted: 2020-02-24 15:49:56
by martin
That's unexpected. Your Nisus Writer files should still sync on Catalina, whether you're using iCloud Drive or another sync service. You mentioned a few of the error messages you see with iCloud. What about your other sync services? Do you see the same error messages, or are they different?

One other question: are you leaving these files open for editing on both Macs simultaneously? That is, assuming you have a single file saved to your iCloud, do you open the same file on both your MacBook and iMac at the same time? I suppose that might interfere with sync, though honestly this is basically outside of our control. Nisus Writer saves the data to iCloud just like anywhere else in the file system; macOS handles the actual sync.

Are you having trouble with any other apps syncing?

Re: Can't sync documents in iCloud

Posted: 2020-02-29 14:22:34
by jconery
Thanks for the reply, Martin. I did some more experiments that tried different applications (Pages, TextEdit, Nisus Writer Express, and Visual Studio Code) and three different sync strategies (iCloud, Dropbox, and a local directory synced by Resilio Sync).

In each test I created a document on one computer, saved it, then opened it on the second computer while it is still open on the first one.

Visual Studio Code works the way I expect it to. Lines can be added to the file on either computer and the changes show up on the other one, and it doesn't matter how the files are synced.

With Pages (editing a .pages document) and TextEdit (editing a .rtf file), if the doc is in iCloud syncing works the way I expect it to. But if the document is in Dropbox or the Resilio-synced directory the doc is not synced. As soon as I save the changes made on the second computer the first one gives me the "document changed by another application" message. It gives me the option of reverting the document, and when I click "revert" the local changes are thrown out and the edit made on the other machine is loaded.

Nisus Writer Express is different than the other two apps. When the document is in iCloud, and then opened on the second computer, it becomes "unsaveable". I can add some text, but as soon as I try to save the document I get the "document could not be saved" error. I see the same error on both machines. But when the document is in Dropbox or the Resilio-synced folder NWE behaves like Pages: the document is not synced, but I do have the option of reverting changes to see the edits made on the other system.

So this is partially a macOS issue (Pages and TextEdit are not syncing outside of iCloud) and partly Nisus Writer Express (not syncing even with the document is in iCloud).

Re: Can't sync documents in iCloud

Posted: 2020-03-03 09:31:37
by martin
Thank you for that detailed information. I'd like to investigate the matter further, to see why Nisus Writer behaves differently than your other apps. Hopefully you are willing to try a special debug version of Nisus Writer that might give us more information. I'll send you a private email to follow-up on this. Thanks!