Nisus Pro files mysteriously convert to Text Edit

Everything related to our flagship word processor.
Post Reply
sirene
Posts: 1
Joined: 2015-01-12 18:14:33

Nisus Pro files mysteriously convert to Text Edit

Post by sirene »

This is driving me crazy. I write a document in Nisus Pro, but the next time I open it by double clicking, it opens in Text Edit and I can't figure out how to get back to Nisus Pro. This has caused me to almost entirely stop using Nisus Pro. Can anybody solve this? I've looked in Preferences and can't see anything I should change. Working on an iMac in Yosemite 10.10.1, if that helps.

Thank you.
Irene

ProfT
Posts: 85
Joined: 2005-03-09 06:53:40
Location: La Mirada, CA

Re: Nisus Pro files mysteriously convert to Text Edit

Post by ProfT »

Irene,

The control over what app opens a particular file type is handled by the OS not the app in most cases. To correct this, use the finder to locate an RTF file. Right click and Get Info on the file. You'll see an Open With option that will allow you to set which app opens all files of the same type.

Once you set that, all RTF files will open with Nisus Writer if you set that preference in the finder.

Mike

Þorvarður
Posts: 304
Joined: 2012-12-19 05:02:52

Re: Nisus Pro files mysteriously convert to Text Edit

Post by Þorvarður »

sirene wrote:I write a document in Nisus Pro, but the next time I open it by double clicking, it opens in Text Edit and I can't figure out how to get back to Nisus Pro.
Hello Irene,
I see you are new here. Welcome to the forum. :)

Just to clarify what Mike said, you need to click on the "Open with" pop-up menu and select Nisus Writer Pro, and *then* click on the "Change All…" button in order to tell the operating system that you wish to open all Rich Text Files (.rtf) in future with Nisus Writer Pro.
Screen Shot 2015-01-14 at 11.47.20.png
Screen Shot 2015-01-14 at 11.47.20.png (21.49 KiB) Viewed 2344 times
If you don't click on "Change All" then the operating system thinks you only want to open this particular file with Nisus, but all others with TextEdit.

This also means that once you have taught the OS to open all your .rtf files with Nisus, you can always individually override this rule by doing what Mike said, and NOT click on the "Change All" button. Then only this particular file will be affected.

If something is not behaving as you think it should, then by all means don't hesitate to ask. We will be glad to help, if we can.

Þorvarður

Post Reply