Default zoom setting for newly converted files?

Everything related to our flagship word processor.
Post Reply
betalogue
Posts: 7
Joined: 2013-11-12 11:48:25
Location: Canada
Contact:

Default zoom setting for newly converted files?

Post by betalogue »

Hi,

Is there a way to select a zoom setting other than 100% for newly converted files when they open in NWP? If I open a .docx file, it defaults to 100%. I open .docx files quite often and it's a pain to have to change the zoom setting every time.

TIA

rfwilmut
Posts: 15
Joined: 2013-11-11 04:23:31

Re: Default zoom setting for newly converted files?

Post by rfwilmut »

You can set a keystroke for your desired zoom level. Preferences>Menu keys>View>Zoom> 125% (or other) then select a keystroke such as command-option-/

You can also add a button for the same menu command to the toolbar; control-click on it and choose 'Add Custom Toolbar Item'.

betalogue
Posts: 7
Joined: 2013-11-12 11:48:25
Location: Canada
Contact:

Re: Default zoom setting for newly converted files?

Post by betalogue »

Thanks. I was hoping to avoid that extra step, but if I have to do that, I will!

ssampler
Posts: 85
Joined: 2006-06-29 07:56:30
Location: Hudson River Valley, NY

Re: Default zoom setting for newly converted files?

Post by ssampler »

Open the file com.nisus.NisusWriter.plist, which will be in your home preferences folder. Make a copy first just in case you mess up. The file should open by default in Xcode. Search for "zoom". There will be an entry for each view: Draft, Page, Full Screen. An example is
2:com.nisus.Writer.DraftView.zoomStyle
. Next to each entry is a Value column. Click in that column and write in your preferred zoom value. (I like 1.42). Repeat for the other Views and save the file when you are done.

Steve
Steve Samuels
sjsamuels@gmail.com

ssampler
Posts: 85
Joined: 2006-06-29 07:56:30
Location: Hudson River Valley, NY

Re: Default zoom setting for newly converted files?

Post by ssampler »

Actually, my suggestion will work only when creating new files. And, editing the plist is unnecessary. Open a new file from the file menu; change the zoom settings for each view in the View Menu; save the changed file as a template file. If you name it "Nisus New File.dot" and put it in NWP's Application Support folder, it will be the default.

So, it looks like a keyboard shortcut is your best bet for opening Word files.

Steve
Steve Samuels
sjsamuels@gmail.com

User avatar
greenmorpher
Posts: 767
Joined: 2007-04-12 04:01:46
Location: Melbourne, Australia
Contact:

Re: Default zoom setting for newly converted files?

Post by greenmorpher »

This is a thing that has nagged at me, too. I have a hi-rez screen on my MacBook Pro (the old 15" hi-rez -- matte too, what a joy to use!) so my standard zoom when working in NWP is 125%. I too would like to be able to have NWP open converted files st 125% rther than 100%. Why not?

Template files are no problem, of course.

Cheers, geoff

Þorvarður
Posts: 341
Joined: 2012-12-19 05:02:52

Re: Default zoom setting for newly converted files?

Post by Þorvarður »

betalogue wrote: Is there a way to select a zoom setting other than 100% for newly converted files when they open in NWP? If I open a .docx file, it defaults to 100%.
Yes, you can do that with a macro. Before you use the macro below, make sure that the Open dialog-box (the dialog box that you are presented with when you hit Command + O, or File > Open) shows the icons in columns! That makes it much easier to spot the Word documents you want to convert.

Menu ':File:Open'
Page View
Set Zoom '180%'
# Don't forget the single quotation marks
Zoom # because converted Word.docx tend to open up "unzoomed" in NWP.

User avatar
martin
Official Nisus Person
Posts: 4936
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Default zoom setting for newly converted files?

Post by martin »

I think in these situations, where a imported file defines no zoom, the file should open with whatever is set in your NWP preferences / new file template. I'll see about getting this changed, thanks.

Post Reply