EUREKA! Font Problems Solved By Deleting NWP Font Menu Cache

Everything related to our flagship word processor.
Post Reply
Posts: 48
Joined: 2013-01-27 17:47:43

EUREKA! Font Problems Solved By Deleting NWP Font Menu Cache

Post by wwgreaves »

For a couple of months I've been experiencing serious problems with Nisus Writer Pro's (NWP's) display of fonts in the Character Palette. My last problem — the display of two typefaces, DIN Pro and DinPro, for one typeface — was serious enough that it froze documents I was working on.

Today, I went to the Genius Bar at my local Apple Store, and a Genius solved my problems by deleting NWP's font menu cache.

Here's the fix:

Shut down Nisus Writer Pro.

In Finder, click Go in the menu bar, press the Option key, click on Library, which will take you to your User Library.

In your User Library, click on the Application Support folder, and then click on the Nisus Writer Pro folder inside it. Inside the Nisus Writer Pro folder is a document entitled Font Menu Cache. Delete it.

Close Finder. Relaunch Nisus Writer Pro, which regenerates the Font Menu Cache using the currently active fonts.

Voila! Problems solved.

Many thanks to Martin, Elbrecht, Groucho, Hamid, and others who helped me attack my font problems. It's nice to have a universal fix. I hope it helps someone else.


Official Nisus Person
Posts: 4757
Joined: 2002-07-11 17:14:10
Location: San Diego, CA

Re: EUREKA! Font Problems Solved By Deleting NWP Font Menu C

Post by martin »

Hi Bill, I'm very happy you managed to get this problem fixed finally! I'm sorry it was NWP's fault after all (with the problematic NWP font menu cache), but it's great news that you can finally enjoy all your new fonts :) thank you for persisting on this issue and sharing your solution with everyone.

Post Reply