Weird Problems with Fonts and Display of Style Pallets

Everything related to our flagship word processor.
Post Reply
Posts: 48
Joined: 2013-01-27 17:47:43

Weird Problems with Fonts and Display of Style Pallets

Post by wwgreaves »

Using Font Book, I just replaced Prensa PostScript fonts (from Font Bureau) with Prensa OpenType fonts. In all my other applications, the OpenType fonts are displayed correctly and can be chosen correctly. HOWEVER, Nisus Writer Pro is still displaying the Prensa PostScript fonts.

I have rebooted my computer (a MacBook Pro running Mountain Lion) several times, and I have cleaned out the font caches (at least three ways) and rebooted my computer. Still no change.

What gives? How can I fix this?

Also, when I diplay my palette drawer on the right, it doesn't open all the way. For example, in the Type palette, the buttons controlling the size of the fonts are hidden by the right edge of the drawer and therefore not accessible. How can I fix this?

Would deleting and reinstalling the program fix these problems? Is there a way to do that?

Official Nisus Person
Posts: 4755
Joined: 2002-07-11 17:14:10
Location: San Diego, CA

Re: Weird Problems with Fonts and Display of Style Pallets

Post by martin »

We replied to you directly on these issues some time ago when you contacted us privately, but for the benefit of the forum, in case anyone else has a similar problem, I'll post here too:

I'm sorry you've had trouble getting your new Prensa fonts to display in Nisus Writer Pro (NWP). I'm not sure what's going on, as generally NWP relies on Apple/OSX to handle how fonts are displayed, but let's walk through the problem together.

When you say that NWP still displays the PostScript font, what do you mean exactly? Do the letters/glyphs appear differently (using the old appearance) on screen in a document, or are the font names somehow distinguishable in the menus?

One possible factor is an OSX feature called "automatic font activation". It is located in Apple's Font Book preferences. If this feature is turned on, then fonts which are not technically installed (but are located somewhere on your hard drive) may be automatically detected and enabled. You might make sure this feature is turned off, to ensure the old font is not getting activated.

As for the problem with your cut-off tool drawer, I'm not sure I can exactly visualize the problem, though I gather some controls are improperly hidden from view. What happens if you simply hide and show the drawer using the View menu? Does that restore the proper drawer width? If not, could you take a screenshot (using the feedback reporter) so I can see the issue?

Posts: 48
Joined: 2013-01-27 17:47:43

Re: Weird Problems with Fonts and Display of Style Pallets

Post by wwgreaves »

I’m sorry to be so late in responding.

A couple of days ago, I sent an e-mail message with five screen shots to you at The screen shots may help you see the problem better.

Today, when I installed the Schadow fonts, the problem I’m reporting with NWP’s treatment of fonts was compounded, so let’s walk through it:

The "automatic font activation” option in Font Book is turned off. It has never been on.

Initially, when I installed Postscript Type 1 versions of the Prensa font, each one was installed separately in its own family, and NWP displayed them separately, which was correct.

Recently, however, I deleted the Postscript versions of the Prensa fonts and then, using Font Book, replaced them with OpenType Postscript versions of the Prensa fonts from Front Bureau.

Now, in Font Book, Ultra Character Map, and Pages, the new Prensa fonts are displayed as a family.

In NWP, using the Show Fonts button on the toolbar, the new Prensa fonts are displayed as a family.

But in the NWP Character Palette, the Prensa fonts are still displayed separately, as the Postscript versions had been displayed.

I have purged my font caches and restarted my computer several times, but this still happens.

Today I installed two Schadow font families from MyFonts. One family (Schadow BT) should contain the Regular and Bold fonts; the other (Schadow Lt BT), the Light and Light Cursive fonts.

That’s the way they are displayed in Font Book, Ultra Character Map, Pages, and through the Show Fonts button on the NWP tool bar.

In the NWP Character Palette, however, only the Schadow BT family is displayed, and in that family only the Regular font is displayed — although hitting the Bold button on the Character Palette gets you the Bold font. Figure that one out!

Finally, as for the palette drawer not opening completely: sometimes it does, and sometimes it doesn’t. Sometimes going in and out of full view will return the drawer to its proper dimensions. And sometimes using the View option as you suggest works, and sometimes it doesn’t. In addition, when the pallette is removed from the drawer it displays correctly.

Many thanks with your assistance with these glitches.

Onward to solutions,

Bill Greaves

Posts: 48
Joined: 2013-01-27 17:47:43

Problem Solved by Deleting NWP's Font Menu Cache

Post by wwgreaves »

For a couple of months I've been experiencing serious problems with Nisus Writer Pro's (NWP's) display of fonts in the Character Palette, including this problem with the display of Prensa fonts as separate typefaces.

Today, I went to the Genius Bar at my local Apple Store, and a Genius solved my problems by deleting NWP's font menu cache.

Here's the fix:

Shut down Nisus Writer Pro.

In Finder, click Go in the menu bar, press the Option key, click on Library, which will take you to your User Library.

In your User Library, click on the Application Support folder, and then click on the Nisus Writer Pro folder inside it. Inside the Nisus Writer Pro folder is a document entitled Font Menu Cache. Delete it.

Close Finder. Relaunch Nisus Writer Pro, which regenerates the Font Menu Cache using the currently active fonts.

Voila! Problems solved.

Many thanks to Martin, Elbrecht, Groucho, Hamid, and others who helped me attack my font problems. It's nice to have a universal fix. I hope it helps someone else.


Post Reply