NWP 2 default fon/template

Everything related to our flagship word processor.
Post Reply
innlaeufer
Posts: 4
Joined: 2009-02-05 01:24:21

NWP 2 default fon/template

Post by innlaeufer »

I find it impossible to change the default font and the new file template from within the preferences, and the template cannot be saved at all. I checked the required file permissions, and they seem ok. I am using the German localization of NWP 2.

BR

User avatar
Hamid
Posts: 762
Joined: 2007-01-17 03:25:42

Re: NWP 2 default fon/template

Post by Hamid »

You are right. The bug affects not only German but all other localized versions as well:

Kunne ikke arkivere dokumentet.
Das Dokument konnt nicht gesichert werden.
No se pudo guardar el documento.
Impossible de sauver le document.
Impossibile salvare il documento.
Nie można zapisać dokumentu.

User avatar
Hamid
Posts: 762
Joined: 2007-01-17 03:25:42

Re: NWP 2 default fon/template

Post by Hamid »

As a temporary fix, I suggest you launch NWP in English by using Language Switcher which you can download from:

http://www.tj-hd.co.uk/en-gb/languageswitcher/

Launch Language Switcher and select Nisus Writer Pro in Language Switcher's pane and chose to launch it in English from the drop-down menu.
Make the changes that you want in NWP Preferences in the English interface and save changes.
Quit NWP and relaunch it as you normally do. It will relaunch in German.

User avatar
martin
Official Nisus Person
Posts: 4902
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: NWP 2 default fon/template

Post by martin »

The bug appears to be that NWP v2 cannot save template (".dot") files when running a non-English localization. Since the Nisus New File is a ".dot" file, the New File preferences cannot be changed.

Some ways to work around the problem:
1. As Hamid suggested, run NWP in English.
2. In your NWP preferences, change your New File Template to a ".rtf" file. This can even be a copy of your Nisus New File that you simply renamed in the Finder.
3. While NWP is not running, open your NWP package and edit the desired lproj's "Localizable.strings" file. You want to remove the entry that looks like:

Code: Select all

"Document Template" = "non-English translation";

Post Reply