Turning Off Unwanted Capitalisation

Everything related to our flagship word processor.
Post Reply
ngazidja
Posts: 142
Joined: 2005-01-23 17:12:16

Turning Off Unwanted Capitalisation

Post by ngazidja »

Just noticed - must be new in whichever upgrade I last downloaded - that when I apply Format>Character Case>Display as Capitalized, rather than simply changing the selected text (as before), it now changes the mode in which I operate. That is extremely annoying and - or me at least - defeates the purpose of the tool.

Eg:

I cut and paste the title of a book from the web somewhere that is written in CAPITALS: "THE COMPLETE GUIDE TO USING ASCII TEXT BY A MAN WITH VERY LITTLE ELSE TO DO".

Ok, I want most of it to be capitalised, so I select the text and do a "Display as Capitalized", and end up with "The Complete Guide To Using Ascii Text By A Man With Very Little Else To Do."

But I don't want it all capitalised. I want "Ascii" to be "ASCII", and I don't really want the "little words" ("to", "by", "a") capitalised. But I can't change them! Every time I try to type a lower case letter at the beginning of a word, Nisus automatically capitalises it. If I try to type a new word (eg, I realise the source quote is wrong and I want to change it by adding "and a Dog" after man, I can only add "And A Dog". And, as if that weren't enough, although the text is now capitalised, the changes have been made at a level that is not transferrable, ie, if I now copy my Capitalised Text and paste it into an email, IT'S ALL IN UPPER CASE AGAIN!

GRRRRRR.

Please tell me I can disable this.

ProfT
Posts: 85
Joined: 2005-03-09 06:53:40
Location: La Mirada, CA

Re: Turning Off Unwanted Capitalisation

Post by ProfT »

The issue is that whatever you type there, you've asked NW to capitalize that text. The solution, then, is to ask NW to not apply the case change attribute to those selected items, or to apply a different case change attribute such as lower case.

So, select the individual words that you wish to change and then either select:
1) Format > Character Case > Remove Case Change Attribute - you can now edit normally

or

2) Format > Character Case > Display As lowercase or > Display as UPPERCASE (depending on how you want it to read)

martin
Official Nisus Person
Posts: 4781
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Turning Off Unwanted Capitalisation

Post by martin »

You could use the menus Edit > Convert instead, which is a one time change and won't affect any future typing you do. That kind of conversion will also copy-paste into other applications without issue, because it changes the actual characters (formatting/attribute case changes are not supported by Mail and some other applications).

ngazidja
Posts: 142
Joined: 2005-01-23 17:12:16

Re: Turning Off Unwanted Capitalisation

Post by ngazidja »

Ah, Thanks Martin, I now see, looking more closely, that there is indeed a difference between "convert" and "view as". I was using the wrong one... :oops:

Post Reply