Editing list of words that stops capitalization after a ".".

Everything related to our flagship word processor.
Post Reply
Sabon
Posts: 19
Joined: 2007-04-14 07:50:39

Editing list of words that stops capitalization after a ".".

Post by Sabon »

How do you edit the list of words that cause Nisus Writer Pro to not capitalize the first word after a period? Like I want the next word after "me." to be capitalized.
We can't stare at Windows all day. We have work to get done.

martin
Official Nisus Person
Posts: 4696
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Editing list of words that stops capitalization after a ".".

Post by martin »

There's no easy/supported way to do this, but it is possible if you don't mind a little mucking about:

1. Quit NWP if it is running.
2. In the Finder, show the package contents for NWP.
3. In the package, edit the file "Contents/Resources/SentenceProfiles.plist"
4. From the list of "KnownAbbreviations" for English, delete the line:

Code: Select all

<string>Me</string>
5. Save the file and relaunch NWP.

Probably that word shouldn't be in there in the first place, as abbreviations are case insensitive and "me" is much more likely that the abbreviation for Maine.

User avatar
greenmorpher
Posts: 767
Joined: 2007-04-12 04:01:46
Location: Melbourne, Australia
Contact:

Re: Editing list of words that stops capitalization after a ".".

Post by greenmorpher »

Martin says:
..."me" is much more likely that the abbreviation for Maine
Or Middle East. :o

Cheers, Geoff

Geoffrey Heard
Publisher, Editor, Business Writer
The Worsley Press

FREE Bonus book offer. Get "How to make great ads for (sm)all business" FREE when you buy "Type & Layout: Are you communicating or just making pretty shapes?" or "How to Start and Produce a Magazine or Newsletter". Amazon or http://www.worsleypress.com

Sabon
Posts: 19
Joined: 2007-04-14 07:50:39

Re: Editing list of words that stops capitalization after a ".".

Post by Sabon »

Thanks. Too bad there isn't a graphical way of doing this under preferences ... :)
We can't stare at Windows all day. We have work to get done.

Post Reply