drag-drop-type bug?

Everything related to our flagship word processor.
Post Reply
credneb
Posts: 166
Joined: 2007-03-28 07:30:34

drag-drop-type bug?

Post by credneb » 2009-05-21 10:42:01

Perhaps I'm not dragging and dropping correctly, but...

When I drag and drop text from A to B, and then proceed to type, the keyboard is dead and the system simply burps. To bring the keyboard back to life, it is necessary to click somewhere (anywhere).

The procedure is double-click to select text, push the mouse button quickly to grab it and without releasing drag to where desired, and then release the mouse button. At this point the text has moved, nothing is highlighted, and the insertion point is at the end of the dropped text as expected. However, typing any key just gets the system bleep. Click again and typing is OK.

Is this a problem with what I'm doing, as intended by Apple, or a problem with NWP?

Using 10.5.6 on a new Macbook Pro and NWP 1.2.

martin
Official Nisus Person
Posts: 4618
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: drag-drop-type bug?

Post by martin » 2009-05-22 10:58:10

That's definitely not how it's supposed to work. I tried to reproduce the problem, but had no luck. It's likely dependent on the contents of both your document and drag-drop. If you hit upon a particular scenario that reproduces the problem, we'd be glad to have a copy of your file and instructions on how to trigger the issue. Please use the menu Help > Send Feedback to send us such a thing, thanks.

credneb
Posts: 166
Joined: 2007-03-28 07:30:34

Re: drag-drop-type bug?

Post by credneb » 2009-05-22 11:58:50

Thank you for the reply, which is both encouraging and disconcerting.

Encouraging because I created a new file, opened and edited a Classic file, and opened a different old NWP rtf file and had no problem dragging, dropping, and editing as expected in any of them.

Disconcerting because the problem has occurred in multiple other files and consistently in the one I'm working on -- just tried it again -- using the procedure described in my first message.

Unfortunately, I cannot send this or the other files because the content is confidential. If the problem occurs in a file I can send, I will.

Thanks again.

martin
Official Nisus Person
Posts: 4618
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: drag-drop-type bug?

Post by martin » 2009-05-22 13:29:15

Thanks for checking. It might be acceptable for you to run the redaction macro on your file, and then submit that if the bug still occurs.

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Re: drag-drop-type bug?

Post by Ruchama » 2009-05-24 07:48:47

Did all this happen only with old classic files?

User avatar
phspaelti
Posts: 1059
Joined: 2007-02-07 00:58:12
Location: Japan

Re: drag-drop-type bug?

Post by phspaelti » 2009-05-28 22:40:00

I can definitey confirm the bug. I have at times edited files where the drag-and-drop operation consistently results in a "freeze". The cursor disappears and trying to type results in a beep. One has to use the mouse and click at a location to re-obtain a cursor and continue work.

Having said that I can also not immediately reproduce the problem. (It may depend on the history of the file.)
philip

credneb
Posts: 166
Joined: 2007-03-28 07:30:34

Re: drag-drop-type bug?

Post by credneb » 2009-06-01 12:51:05

re: did all this happen only with old Classic files?

I'm not sure. I cannot reproduce it at will, and drag-drop works fine in the documents I've been working on since I posted. I'll try the redact macro the next time the problem occurs.

Post Reply