Reformatting existing footnote references

Everything related to our flagship word processor.
Phrasikleia
Posts: 16
Joined: 2008-01-08 00:08:53

Reformatting existing footnote references

Post by Phrasikleia »

One of the great flaws of MS Word is its inability to have the format of the footnote references be different in the notes from what it is in the main text. For example, it is impossible to have--as many style guidelines require--superscript references in the main text while references in the notes are generated without superscript and with a period following the number. The only workaround is to manually change each number in the notes or use a macro to do it for you.

NWP, to its credit, offers controls in the footnotes style box to differentiate between "Doc Reference Style" and "Note Reference Style" (bravo!). However, it only seems applicable to notes generated AFTER the necessary changes to footnote and character styles have been made. If I open a document that was created with a single definition of note references, there appears to be no way to get NWP to change the notes already existing in the document; it will only apply the new, differentiated formatting to subsequently created footnotes.

Is this behavior a bug?

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Post by Ruchama »

no- you are wrong (i think) - you can change styles in footnotes. but you should not open a new style but the existing style of your notes. you should click on view style while standing in the notes- and then make your changes.

(naturally- you may need to select all notes to apply changes to all of them).

Phrasikleia
Posts: 16
Joined: 2008-01-08 00:08:53

Try this

Post by Phrasikleia »

no- you are wrong (i think) - you can change styles in footnotes. but you should not open a new style but the existing style of your notes. you should click on view style while standing in the notes- and then make your changes.

(naturally- you may need to select all notes to apply changes to all of them).

Ruchama, I'm not sure you understood me exactly. Try this:

1) Place your cursor within the footnotes of a document and click on View Style, as you suggested.

2) Within the Footnote Style options, type a period in the box for "Default Note Text"

I think you'll find that the periods will not appear after the footnote reference numbers in the notes that are already in the document, but they will appear for any new notes you make.

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Post by Ruchama »

you are right concerning this specific option- tried it and it did not work. however other attributes in the same style window do work so it seems to me like a(nother) bug. annoying.

Phrasikleia
Posts: 16
Joined: 2008-01-08 00:08:53

Or try this

Post by Phrasikleia »

The more I play with footnotes, the more bugs I find. Here's another sequence to try:

1) Select just the number of a superscript footnote reference within the footnotes and click on View Style.

2) Click on the Superscript button in the Character Palette to deselect it.

You'll find that all the footnote references in the notes themselves will change, losing their superscript attribute. The reference numbers in the main text will remain superscript.

3) Now repeat the first two steps in an effort to get the superscript you just removed to come back.

It won't.

Ruchama
Posts: 213
Joined: 2006-08-19 18:35:27

Post by Ruchama »

you are right again, it seems there is no way to separate the attributes of the number and that of the text once the superscript was cancelled.

martin
Official Nisus Person
Posts: 4826
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Try this

Post by martin »

Phrasikleia wrote:1) Place your cursor within the footnotes of a document and click on View Style, as you suggested.

2) Within the Footnote Style options, type a period in the box for "Default Note Text"

I think you'll find that the periods will not appear after the footnote reference numbers in the notes that are already in the document, but they will appear for any new notes you make.
This is the intended behavior. The default text is only for new notes and will not change any of your existing notes.

martin
Official Nisus Person
Posts: 4826
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Or try this

Post by martin »

Phrasikleia wrote:1) Select just the number of a superscript footnote reference within the footnotes and click on View Style.

2) Click on the Superscript button in the Character Palette to deselect it.

You'll find that all the footnote references in the notes themselves will change, losing their superscript attribute. The reference numbers in the main text will remain superscript.

3) Now repeat the first two steps in an effort to get the superscript you just removed to come back.

It won't.
Using a freshly created document I had no trouble with these steps. It may be that your note styles are configured differently. If you send the document to me I can have a look, however here are some things to be sure of:

1. you don't have any font overrides applied to your note references. You can check for overrides by noting the appearance of the font tag (the little black "a" icon at the bottom-right corner of every document window).

2. When you move to the stylesheet view, make sure that just the character/reference style is selected. You don't want to change the note style itself.

Phrasikleia
Posts: 16
Joined: 2008-01-08 00:08:53

Overrides

Post by Phrasikleia »

Martin, it sounds as though you added a step: you deselected the Footnote style in Style Sheet view before completing my step 2). In that case, you'll be changing both sets of reference numbers (i.e. both in the text and in the notes themselves), removing superscript from all of them. My goal was to have ref numbers in the notes that could be reformatted independently of the numbers in the text.

I see now that it is possible to edit multiple styles at once, something I hadn't expected. Yes, I had indeed created a character override (unwittingly). Trying again, I made the differentiation with a character style and was careful never to be editing more than one style at a time. Success!

In the process, I found that the override indicator sometimes displays only in Style Sheet view (and disappears upon returning to page view). I'll experiment some more and start a new thread if I can't figure out why that is.

martin
Official Nisus Person
Posts: 4826
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Overrides

Post by martin »

Phrasikleia wrote:Martin, it sounds as though you added a step: you deselected the Footnote style in Style Sheet view before completing my step 2). In that case, you'll be changing both sets of reference numbers (i.e. both in the text and in the notes themselves), removing superscript from all of them. My goal was to have ref numbers in the notes that could be reformatted independently of the numbers in the text.

I see now that it is possible to edit multiple styles at once, something I hadn't expected. Yes, I had indeed created a character override (unwittingly). Trying again, I made the differentiation with a character style and was careful never to be editing more than one style at a time. Success!
I'm glad you got it working- all the same, I'd like to clarify exactly how the reference styles work.

When you switch into the stylesheet, coming from the main document where a footnote reference was selected, two styles will be shown and selected. The first is the Note style, by default called "Footnote", and is a paragraph style that is applied to all content in the footnote, reference number and all. Basically it's like "Normal" for footnotes.

The other style is the Character style, called "Footnote Reference", which is applied to only the note reference. However, by default this style is applied to the reference in both the document text area and the footnote text area. To properly differentiate the formatting for these areas you need to create a new Character style, say "Reference in Body", and then set your Note style to use it. Only then can you select one of the two reference Character styles and properly remove the superscripting.
In the process, I found that the override indicator sometimes displays only in Style Sheet view (and disappears upon returning to page view). I'll experiment some more and start a new thread if I can't figure out why that is.
This is how it works: the font tag only shows if there is a font override applied to the selection. In the document view it appears if you have non-style attributes (eg: formatting that does not come from a style) applied to the selected text. In the stylesheet view the tag only shows if the style defines font attributes different from the "based on" style.

Hopefully all that makes sense and helps some.

Phrasikleia
Posts: 16
Joined: 2008-01-08 00:08:53

Re: Re: Overrides

Post by Phrasikleia »

I'm glad you got it working- all the same, I'd like to clarify exactly how the reference styles work.

When you switch into the stylesheet, coming from the main document where a footnote reference was selected, two styles will be shown and selected. The first is the Note style, by default called "Footnote", and is a paragraph style that is applied to all content in the footnote, reference number and all. Basically it's like "Normal" for footnotes.

The other style is the Character style, called "Footnote Reference", which is applied to only the note reference. However, by default this style is applied to the reference in both the document text area and the footnote text area. To properly differentiate the formatting for these areas you need to create a new Character style, say "Reference in Body", and then set your Note style to use it. Only then can you select one of the two reference Character styles and properly remove the superscripting.
Thanks for the clarification, although this approach was actually the very first one I took, after having spotted the options for different "Doc" and "Notes" reference styles in the Footnote style sheet. In this regard, the interface of NWP is very intuitive. What was unclear to me then was that I was editing multiple style sheets at once, thus creating those troublesome overrides. I know of no other application that allows the simultaneous modification of multiple styles (other than by "based on" functions), so I wasn't expecting it.
This is how it works: the font tag only shows if there is a font override applied to the selection. In the document view it appears if you have non-style attributes (eg: formatting that does not come from a style) applied to the selected text. In the stylesheet view the tag only shows if the style defines font attributes different from the "based on" style.

Hopefully all that makes sense and helps some.
That makes perfect sense: both the logic of this functionality in the application and your concise summary of it. Thank you!

stackowax
Posts: 7
Joined: 2008-04-11 08:12:34

Reformatting existing footnote references

Post by stackowax »

I'm trying to figure out how to make the numbers in my footnotes that appear at the bottom of the page have a period after them. Like this:

1. blah blah blah
2. blah blah blah

Right now they look like this

1 blah blah blah
2 blah blah blah

(The numbers that appear in the body of the text are fine and I want them to stay that way (they are superscripts).)

When I place the cursor in the footnote section at the bottom of the page and click on the style sheet, 3 styles appear, in this order (I will list the attributes are listed after each style as well):

Note Reference

Normal

Footnote

Screenshot of style sheet showing Note Reference and Normal settings:
http://www.flickr.com/photos/21716428@N ... 4/sizes/o/

Screenshot of style sheet showing Footnote settings:
http://www.flickr.com/photos/21716428@N ... 8/sizes/o/

I've read Martin's explanation in this thread and it doesn't make sense to me (maybe in part because there isn't a clear distinction being made between the footnote number that appears in the body of the text and the footnote that appears at the bottom of the page (which includes a number and text). But I think there is something else that I'm not understanding here.

martin
Official Nisus Person
Posts: 4826
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Reformatting existing footnote references

Post by martin »

Almost all of my replies in this thread are dedicated to discussing the attributes/formatting of Note styles. That is separate from the "default text" property, which is only mentioned here:
the default text is only for new notes and will not change any of your existing notes.
Which is the limitation that's stopping you from inserting the periods you'd like.

So, if the default text only applies to new notes, what can one do for existing notes? You'll have to use a macro. I've written one here, that inserts periods at the start of every note in your document:

Code: Select all

While Select Next Note
	If Find '(.*)\s', 'Es$'
		If '.' != $1
			Select Start
			Type Text '.'
		End
	End
End
Just place the caret at the top of your document and run that code once. I hope that helps.

Anne Cuneo
Posts: 164
Joined: 2004-09-23 02:15:46
Location: Switzerland
Contact:

Re: Reformatting existing footnote references

Post by Anne Cuneo »

What about changint footnotes into endnotes?
I ended up doing this manually, but I am sure there must be another way.
Anne

Kino
Posts: 400
Joined: 2008-05-17 04:02:32

Re: Reformatting existing footnote references

Post by Kino »

Anne Cuneo wrote:but I am sure there must be another way.
AFAIK there is no other way than to simulate the manual operation. So the macro below is something very insipid. NW Macro language has a note object property .place but it is read-only, unfortunately.

Code: Select all

$doc = Document.active
$notes = $doc.allNotes
if ! $notes.count
	exit 'No note found, exit...'
end
$noteRefsInBody = Array.new
foreach $note in $notes
	$ref = TextSelection.new $doc.text, $note.documentTextRange
	$noteRefsInBody.appendValue $ref
end
$doc.setSelections $noteRefsInBody
Menu ':Format:Note Style:Endnote'
If you are running NW Pro with a localised interface, you have to change the menu command path (the last line).

Post Reply