Missing Footnote divider line?

Everything related to our flagship word processor.
Post Reply
Vanceone
Posts: 158
Joined: 2013-05-03 07:06:31

Missing Footnote divider line?

Post by Vanceone »

So this is a bit odd. I'm using Nisus 3.2, on the latest Mojave.

My footnote divider line is missing when I save it as a PDF. It shows up on the screen, but when I save as, or export to PDF, or save as a PDF from the print screen, the footnote divider line is just gone.

I went and redownloaded Nisus 3.1 and opened the exact same document (gratefully there was no incompatibilities there) and that version successfully exported the footnote divider line, so it doesn't appear to be my system or the Quartz PDF printer driver.

I confirmed it this morning by creating a new document in 3.2, writing a line of text then a footnote, then exporting to PDF. No divider line in the PDF, but it does show on the main editing screen.

The line does not show up on the little print preview image, however, and also does not physically print.

Am I missing a setting somewhere, or did I just uncover a bug? Thanks to all the true Nisus Gurus out there!

adryan
Posts: 410
Joined: 2014-02-08 12:57:03
Location: Australia

Re: Missing Footnote divider line?

Post by adryan »

G'day, vanceone et al

I use NWP 3.2 with Mojave. For me, the footnote dividing line shows both on the screen and in PDFs created by Nisus's Export As PDF command, as well as in PDFs created via the Print dialog box.

I've only had a quick look at where your problem might lie. The only place I can see where you can influence the appearance of the footnote dividing line is in the Style Sheet, but I'm not sure why you would see it on the screen and not in a PDF. I wonder whether parking your existing NWP Preferences file somewhere safe and relaunching NWP (which would create the Preferences file anew) would give a clue. All I can think of, I'm afraid.

Cheers,
Adrian
MacBook Pro (mid-2014)
macOS Mojave 10.14.6
Nisus Writer user since 1996

User avatar
martin
Official Nisus Person
Posts: 4902
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Missing Footnote divider line?

Post by martin »

The footnote divider line seems to export to PDF just fine for me, using version 3.1 and 3.2. If you're still having trouble Vance, could you please send us an example document that exhibits the problem? I'd like to test using your exact materials, to investigate this further. It might help if you also send us the PDF that erroneously lacks the divider line. Thanks for your help!

Vanceone
Posts: 158
Joined: 2013-05-03 07:06:31

Re: Missing Footnote divider line?

Post by Vanceone »

I sent some documents to you Martin.

I figure there is something wrong with my setup somewhere, I can't imagine that if this were a general bug it would have only affected me or gotten through your beta or other testing. I hope your wizards can figure something out!

I honestly don't think a corrupted preference file is at play; as far as I know there aren't any settings regarding the footnote divider line (I don't think it can be turned off at all, normally). So a bit of a mystery!

Vanceone
Posts: 158
Joined: 2013-05-03 07:06:31

Re: Missing Footnote divider line?

Post by Vanceone »

So after some investigation, this problem may only show up when you are in dark mode. Good hunting Martin! Therefore, until this bug is fixed, if you have footnotes you should switch to light mode before printing/exporting to PDF.

User avatar
martin
Official Nisus Person
Posts: 4902
Joined: 2002-07-11 17:14:10
Location: San Diego, CA
Contact:

Re: Missing Footnote divider line?

Post by martin »

We just released version 3.2.1 that should fix this Dark Mode divider line issue, among others.

Post Reply