Page 1 of 1

file icons aren't in Finder, but are in GetInfo

Posted: 2019-07-02 12:21:28
by sgtaylor500
I've tried everything I know, including booting in Safe Mode, Maintenance (little brother of Onyx) for High Sierra, removing via UninstallPkg (CoreCode, Ltd) and installing fresh. I do have a copy on Pages installed. It's a fairly fresh install of High Sierra, too.

Edit: At any icon size below 184 x 184 they don't show up as document icons.

Re: file icons aren't in Finder, but are in GetInfo

Posted: 2019-07-03 07:44:51
by martin
It sounds like you're saying that files saved by Nisus Writer lack a distinctive icon. You were probably expecting to see our app icon inside a standard document icon, which looks like this:
docicon.png (31.16 KiB) Viewed 2971 times

I assume your files are RTF files with the .rtf file extension, which means the custom Nisus document icon is probably being replaced by Apple's QuickLook preview thumbnail. That's a tiny preview of the text and contents inside the file. It looks something like this:
quicklook.png (12.62 KiB) Viewed 2971 times

Is that what you're seeing? If so, then that's the expected system behavior, even if it isn't very helpful. In my screenshot the words "HELLO WORLD" inside the document text are using a huge font size (120 points), which is why they're visible in the icon at all. Any regular text (eg: a 12 point font) is impossible to read.

There is one way to prevent these QuickLook preview icons, if you don't mind switching your document file format. If you save your files using our custom Nisus Compressed RTF file format (with a .zrtf file extension) there's no QuickLook preview, and thus you'll see the custom Nisus file icon.

Re: file icons aren't in Finder, but are in GetInfo

Posted: 2019-07-20 15:21:45
by sgtaylor500
That worked. Thank you; I now have a path to troubleshoot - it's a QuickLook issue.

I will get back to you all if I find a true solution.

Re: file icons aren't in Finder, but are in GetInfo

Posted: 2019-07-20 16:07:17
by sgtaylor500
Courtesy of Howard Oakley of the Eclectic Light Company blog: ... quicklook/
  • If all else fails, and you have to force the IconServices cache to be rebuilt, the only way seems to be to delete it at the command line. Because these caches are protected by permissions, this means using sudo and entering potentially dangerous commands, so make sure that your Mac is fully backed up before even thinking about doing this.

    The command to remove the main store is

    Code: Select all

    sudo rm -rfv /Library/Caches/
    That for the subsidiary data is

    Code: Select all

    sudo find /private/var/folders/ \( -name -or -name \) -exec rm -rfv {} \;
    which includes the Dock icon cache too.
... and that really fixed it, after a reboot and a short wait for the system to rebuild everything.